I've tried EVERYTHING to get my files back into my name, but all I seem to do is add MORE files to Root ownership every time I try to fix things.

It starts with getting my 2 ntfs partitions to mount at startup. Pysdm will set the partitions to mount, but then it also makes everything owned by root. I change the ownership, and it just doesn't "take". There's no error messages, the next time I open the program, everything is right back to being owned by Root. I tried running it with sudo via terminal, and changing it then, but it still didn't take, and seemed to create more permission problems (that I can't remember right now, sorry). Then I read that using sudo would change the permissions to root on it's own, and I should use gksudo or gksu, and THAT should work, but it did nothing.

I reinstalled Ubuntu, and tried just manually editing the fstab file, but that didn't work either. I kept getting errors on bootup that the partitions couldn't be mounted. Plus I had weird extra non-existent drives just sitting there all the time. I'm sure I did something wrong there, but I checked it a MILLION times and everything looked in perfect order. Those phantom drives where NOT in my fstab file.

SO! I reinstalled Ubuntu AGAIN, and try NTFS-config instead, as recommended. It mounts my drives, and AGAIN, changes ownership to Root and I can't unmount them if I want. I try to change it back with CHOWN -hR myname:myname /media/[the drives], and it changed all the ownership of all my FILES to root too. These files were already owned by me, and with the command to change everything to my name, it changed everything to root. now I'm really screwed.

Perhaps the weirdest: I tried accessing Nautilus with sudo AND gksu, and when I try to change the permission with the gui, by right clicking and changing the ownership and group, I select my name from the menu, it shows my name for a second, and then IMMEDIATELY reverts back to root. It just won't "take" either.

WHY!?!?!?! WHY does everything keep changing to root!? Why do all my attempts function enough to change the ownership, but only to root and not back? Please help!!!


NTFS partitions do not honor linux permissions. So any permission change done using chmod will not be applied permanently.

You have to write an fstab line using options defaults,uid=1000,gid=1000 where uid and gid can be found for your user using command id.

You may add this under "Options" in pysdm if I'm not mistaken.

Similar question: How to write an fstab line for full access to an NTFS drive?

On the other hand, you could format the partition to ext2 / ext3 / ext4 and use a browser program in windows, like ext2read: http://sourceforge.net/projects/ext2read/

Other options are the ext2/3/4 driver for windows, ext2fsd: http://www.ext2fsd.com/


This article solved my issues with NTFS permissions:

Mount NTFS partition at startup, with non-root user as owner

The trick was to modify my NTFS drive's mount entry in my /etc/fstab file to use "ntfs-3g" with the "permissions" and "users" options.

UUID=####    /mnt/MOUNTPOINT    ntfs-3g    defaults,permissions,users    0    0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.