I'm running 12.04 LTS and I can't seem to see any thumbnails for pictures, videos, anything. I have checked my preferences "Show Thumbnails, Always, files under 10MB, Local Only" which makes sense but still, no thumbails.

I was having problems with Unity 3D and my nvidia card and I entered a force_unity_start code somewhere. Now I got gnome 3 working (turns out i just had to turn zoom off) I'm still having this problem.

please advise if you need any more information to help me with this!

  • I'm having the same problem. Mine started when I decided to delete the thumbnail cache, I can see that it's being re-generated but nautilus doesn't show any thumbnails. Always loading... If you find out a solution, please let me know
    – Felipe
    Sep 28 '12 at 18:16

I fixed this issue by fixing the permissions on


That is sudo chmod 777 -R .cache/thumbnails

Hope that helps

  • +1 All the answers regarding ~/.thumbnails do not work, but this one does. Nov 18 '13 at 1:10
  • also works for thunar thumbnails.
    – GeoMint
    Jun 30 '16 at 11:52

I had that exact same problem. I am using Linux Mint Debian Edition and in my case I had upgraded some packages grabbing them from the experimental branch. Manually downgrading all those packages fixed the issue. Hope this helps.

  • Which packages?
    – Kazark
    Oct 30 '12 at 4:14
  • 1
    Sorry @Kazark... I never checked this again. Looking at my bash history, I see I obtained the list of packaged installed from the experimental branch in my system, using: aptitude search '?narrow(~i,~Aexperimental), and then I downgraded one by one. The packages I manually downgraded were:
    – deivid
    Nov 21 '12 at 15:08
  • libebackend-1.2.5 evolution-data-server evolution-data-server-common libedata-book-1.2-15 libebackend-1.2-5 libedata-cal-1.2-15 folks-common libfolks25 geoclue geoclue-hostip geoclue-localnet geoclue-manual geoclue-yahoo gsettings-desktop-schemas gtk2-engines-pixbuf libgtk2.0 libgtk2.0-bin libgail18 libgail-common libcairo-gobject2 libcairo2 libcairo2.0-0 x11proto-dri2-dev x11proto-gl-dev libglib2.0-0 libglib2.0-0-bin glib-networking glib-networking-common glib-networking-services libsoup2.4-1 libsoup-gnome2.4-1 girl1.2-soup-2.4. But I don't know which specific one was causing the issue.
    – deivid
    Nov 21 '12 at 15:23

Other related bugs suggest changing permissions on ~/.thumbnails or linking ~/.cache/thumbnails to that location. I have U 11.04 from an upgrade of 10.10 install. Nautilus is not updating its icons with thumbnails even though it is trying to write something into the first directory above.

I checked the effective UID GID pair in /etc/passwd and compared it to the numerical UID and GID in the permissions:

grep user /etc/passwd
ls -n -d ~/'thumbnails

They match. Since I did an upgrade I was testing the hypothesis that the upgrade changed the UID and GID of the user in the password file but not in the file ownership. That is not the problem, here. The file manager has another problem.

Looking at the png files in .thumbnails/normal shows that they were updated the last time the file manager was opened, reasonable dates and times of access, but that they did not have thumbnails of the files. In U 10.10 I used to get thumbs of images and HTML files and some other types, but no more.

I am weary of breakage in U every time it rolls a rev, and how fast systems fall out of support. It is making me think of looking for a more stable Linux.


Had the same problem with Ubuntu 13.10 - Gnome3. Solved it deleting whole folder thumbnails in /.cache and remaking it.

1) Disable preview in nautilus by opening home folder, Edit-> Preferences-> Preview.

2) sudo rm ~/.cache/thumbnails

3) Empty trash can

4) sudo mkdir ~/.cache/thumbnails

5) Reboot

6) Enable preview, again home folder, Edit-> Preferences-> Preview.


Worked for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.