After chasing around an unfortunate bug wherein my Dell's Nvidia GeForce FX 5200 requires a driver other than either nouveau or nvidia-current, I came across this: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-173/+bug/948053

Trouble is I'm not certain how to proceed from here - and I'm also really, really cautious about doing this, because the last two or three times I tried to install drivers for this card I ended up with bad resolution and/or a blank screen, and I did end up reinstalling Ubuntu at least once.

I'm fairly positive that there's no error with the card as it worked under Windows XP on the same machine not a month ago, so I believe the error was human. :/ What's the best way to install based on the information in the link above, and if it goes belly up, what's the right way to reverse it? I'm not terribly excited to reinstall again :) Thanks.

  • possible duplicate: Nvidia driver cannot be installed with jockey for old hardware
    – TrailRider
    Jul 16, 2012 at 1:44
  • So the correct driver is available in the regular apt-get repository? I've very very new to Ubuntu. How do I interpret the information on the bugs.launchpad site? AFAICT the current downloadable version for Pangolin is 173.14.30, whereas the actual fix is under 173.14.35 and looks to be available to Quetzal and not Pangolin, unless I'm reading the "Overview" page all wrong.
    – Stick
    Jul 16, 2012 at 2:58

4 Answers 4


At least for my part, I believe this is solved.

Recently, the driver I was reading much about - 173.14.35 - was released in a means that I could access and install using apt-get. The link in the original question leads to the announcement that nvidia-173 on precise-proposed has been updated to xxx.xx.35, and so it's a matter of following the directions listed on this page: https://wiki.ubuntu.com/Testing/EnableProposed

As this is a rather new fix, I will not guarantee it works for everyone with a legacy Nvidia card under Ubuntu 12.04. But for my money this was far favorable to downgrading Xorg or rolling back to an older OS.


The following simple steps worked for me for version 12.04.02 on March 19, 2013.

  • Install 12.04.02 (DO NOT enable auto login).
  • When the install finishes rebooting, you will be at the login screen (DO NOT LOGIN).
  • CTRL-ALT-F1 to get to a command-line.
  • login at the command prompt
  • sudo apt-get install nvidia-173-updates (DO NOT INSTALL nvidia-173)
  • reboot
  • enjoy

Nvidia 173 drivers to work is by downgrading the xorg-xserver, so this is what we're going to do.........

Create /etc/apt/sources.list.d/oneiric.list and add the oneiric repo (You can copy/paste the text of the following entirely on a terminal

sudo -s

sudo cat >/etc/apt/sources.list.d/oneiric.list <<EOF

deb http://archive.ubuntu.com/ubuntu oneiric main

deb-src http://archive.ubuntu.com/ubuntu oneiric main


You will need also to perform a "pinning" so the xserver-xorg will be chosen and kept to be the older version and not the latest.

Create a new file in /etc/apt/preferences.d/

cat > /etc/apt/preferences.d/xorg-xerver-pin-1050 <<EOF

Package: xorg xserver-xorg*

Pin: release a=oneiric

Pin-Priority: 1050

Then run,

sudo apt-get update & sudo apt-get dist-upgrade

This will warn you it's going to downgrade a lot of "xorg" related packages, that's exactly what we need

Download Nvdia-173 driver from here

Once downloaded, you need to stop the GUI, so get to the terminal by pressing Ctrl+Alt+F1 login with your user and stop the xserver with

sudo service lightdm stop

Go to the place where you saved it (most probably in your home downloads folder)

cd ~/Downloads

and run the following

sudo chmod +x NVIDIA-Linux-x86-173.14.31-pkg1.run & sudo ./!$

Follow the onscreen instructions, mostly "yes" to all and once it finishes reboot the computer. Voila! You're now using the nvidia driver with full 3D support! If you want to configure other settings, you can use the nvidia-settings application that you have now installed. If you change something and want to save it, you'll have to run it as root, so you better fire it up by pressing Alt+F2 and on the command type gksu nvidia-settings

  • Wait, what? Didn't Nvidia just put out an update to nvidia-173 that's supposed to prevent you from having to do all this? That's what I thought 173.14.35 was all about.
    – Stick
    Jul 16, 2012 at 3:39
  • Is there any way I can just point apt-get at a repository that DOES HAVE 173.14.35 available? I only see it up for the next version of Ubuntu.
    – Stick
    Jul 17, 2012 at 22:24

Just add the following to your /etc/apt/sources.list file:

deb http://cz.archive.ubuntu.com/ubuntu precise-updates main restricted

Then you can

sudo apt-get install nvidia-173-updates

I had nvidia-304 installed so I had to do:

sudo apt-get install -f 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.