I'm on Ubuntu 12.04.

Everything was fine until I did a fresh install of a proprietary driver for NVIDIA, using the "Additional drivers" utility. After having restarted my computer, I cannot access to my session as usual anymore.

Different things can happen:

  • It starts under Ubuntu GNU GRUB with Linux 3.2.0-26-generic-pae, and it looks like a terminal, I can log in and all. startx gives me weird colored patterns on the screen and keeps frozen.
  • It freezes immediately with the weird patterns, or with just a purple screen and my cursor after showing the "Ubuntu" login purple screen.
  • Or it shows the usual login screen, but completely deformed, and unusable.

I tried sudo dpkg-reconfigure nvidia-current to fix my problem, but it didn't work.

Could you help me please ?

  • I know this may not very helpful. But My general recommendation is not to upgrade working graphics driver, unless you see problems. – Anwar Jul 15 '12 at 15:17
  • You're right, I will be careful about that in the future. – Chinouk Jul 15 '12 at 16:07

Try removing your freshly installed Nvidia driver and go back to the open-source driver, Nouveau. Log in to the command line interface of Ubuntu, launch sudo apt-get install nouveau-firmware (just in case) then follow the instructions at https://askubuntu.com/a/12941/5592:

To reconfigure xorg.conf, type the following command:

sudo dpkg-reconfigure xserver-xorg

Go following the screen steps, answering the wizard questions and you should able to restore or reconfigure to previous Nouveau state.

After that, if this solved your problem, you will probably have a very low resolution. So launch the "Displays" utility from the Dash home and adjust your resolution accordingly to fit your screen the best.

| improve this answer | |

I had a similar problem. Solved like this:

  1. Boot as normal and get to login screen

  2. press Ctrl + Alt + F1

  3. Login with your username and password.

  4. type sudo stop lightdm and press enter, stops X11

  5. type sudo apt-get purge nvidia* and press enter -clears all nvidia items

  6. type sudo apt-get install xserver-xorg-video-nouveau and press enter- will install this package or tell you if it is already there.

  7. type sudo reboot

this got me back up and running (although no icons in unity launcher - since need correct graphic drivers) check system settings to search for Additional drivers to see if this cab be addressed - although adding wrong drivers may cause the system to be faulty or freeze after login.

| improve this answer | |
  • Helped me with incompatibilities between nvidia drivers and Linux 4.4/Ubuntu 16.04. Reverted to nouveau driver using your procedure. Thanks – mathieu Apr 24 '16 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.