I downloaded the driver of Nvidia 610m driver on http://www.geforce.com/drivers but I don't know how to install it in ubuntu.It is my first time to use ubuntu. I've already read some answers from the same topic as mine but I don't understand and don't know how to use the terminal.

Please help me.Thank you! :)


3 Answers 3


Your 610M is an Intel/Nvidia hybrid card, and it is not officially supported by Nvidia. See this link here for installing the drivers: Switchable laptop graphics issues on Ubuntu 12.04?

  • Thanks. I'll try it when I'll get time to do it. So much busy with school works!:) Jul 22, 2012 at 7:29

Don't use Nvidia X server settings, if there are no proprietary drivers (see: system>additional drivers). It won't work, only spoil the system if you try nvidia-xconfig as root. It will set screen resolution to 640*480.

After searching http://www.nvidia.com/object/linux-display-amd64-302.07-driver.html, http://bumblebee-project.org/ and some posts on http://askubuntu.com I resolved to stay within Ubuntu and typed following lines into terminal (to open terminal you can 'ctrl+alt+t'):

sudo apt-get purge nvidia-current
sudo apt-add-repository ppa:ubuntu-x-swat/x-updates 
sudo apt-get update 
sudo apt-get install nvidia-current

After first sudo you will need to enter password. It takes time between each of line to perform actions. After succesful exec exit terminal and restart OS. Now my screen looks fine and comp (Asus K55V with GEFORCE 610M, Ubuntu 12.04.1 LTS 64bit) works good. There still are no additional drivers.

I installed 'Stellarium', that uses opengl. It didn't start, because "no opengl"

Than I entered in the terminal following lines:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update && apt-get install bumblebee-nvidia

I suceeded only after 3-rd atempt becouse of server problems. First two attempts ended up with some "E:" lines.

After that 'stellarium' started sucessfuly. I noticed, that nvidia-current is fitted for a defined kernel, so after update U need to repeat this all again. Shoul those lines be in some script?

And try this:


optirun glxsperes

I noticed diference ~3 times. And yes, there still no additional drivers.


Don't. Use "Additional Drivers" from System Settings, which can be opened from the menu in the top-right corner.

  • I already tried that but tt says: "No proprietary drivers are in use on this system." Jul 15, 2012 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.