When my external HDD mounts, it get mounted with root as owner. So I can only look read files. How do I get this to mount as me as owner?

It's frustrating. Why is it really necessary to have root as the owner. Can't you just have a admin account that get that privilege?

As I have read, there are no way to set fat32/NTFS with owner. So there are no way I can change this. Atleast not that I am aware of.

I hope anyone one here can help me.

Update: It's labeled as vfat, not fat32. Not sure if that is the same thing. Update 2: The screenshot show my language, but I do believe you know what it means. I will add mount shortly.

Screenshot of the owner rights on my vfat external HDD Mount gives the output vfat (rw)

  • 1
    In Ubuntu, external HDD partitions mount as user readable and writable by default, not sure what's the source of your info. Also, 'root-permissions' are irrelevant in case of fat32. Add the output of mount to the question, that might help us help you. What version of Ubuntu do you have? – mikewhatever Jul 14 '12 at 22:21
  • I use ubuntu 12.04. I will add the output of mount later today. When I right click on my HDD and choose properties. And choose the tab Rights (I think it's called that in English, it's the second tab). The root is shown as owner. I will make a screenshot to. – user66987 Jul 15 '12 at 11:30
  • mount your drive. It will show in /media/drivename. Now change the permission: sudo chmod -R 777 /media/drivename – shantanu Jul 15 '12 at 12:42
  • I have tried to change owner with chmod earlier, but I gave it a try again. Root is still the owner. And when I try to change 777 to my username, I get "chmod: invalid mode" followed by my username. The strange thing is, when I use 777 I do not get invalid mode, but the owner is still root. – user66987 Jul 15 '12 at 12:59

I have solved it. I used the guide mount guide

Ok. Here is the steps I used.

  1. Unmount drive. Used this command in terminal sudo umount /media/your disk.
  2. I checked the partition table to see what path it was on with this command sudo fdisk -l in terminal.
  3. I created a mount point sudo mkdir /fat. Just called it fat.
  4. Then I created a backup of my fstab file using the command sudo cp /etc/fstab /etc/fstab_backup.
  5. Then I opened fstab with this command sudo nano /etc/fstab.
  6. Then I added this to my vfat HDD iocharset=utf8,umask=000 0 0

And voila, when I mounted the HDD again I was the owner and not root :)`

The site I added also explains how to do this for NTFS HDD's too.

  • Please edit your answer to tell us specifically what you did to fix the problem--that's better than a web reference that might go away some day. Please leave the reference in your answer, though. Helpful sites deserve links (and credit). – John S Gruber Jul 15 '12 at 15:47
  • Great! Thanks for documenting what worked for you. – John S Gruber Jul 15 '12 at 20:16
  • user66987 you are a legend, many thanks this also solved my issue. – Huw May 8 '14 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.