The problem is, my Wireless network connection cannot connect. It's only worked if I plugged in the cable and then used the Internet for a while,

after being assured that I am connected, I will remove the cable and start using Wifi. This works just for a while, but when I restart I will have to do the same thing again.

After connected to the wired network, I try to bring my netbook away from the modem, I am still connected if I am nearby to my modem that located upstairs of my house. Then if I go downstairs, the connections is fading away but the wireless indicator still indicate 100% active.

Downstairs, I can't access the internet at all even though the indicator shows 100%. If I want to connect to the internet again, I have to go upstairs, put in the cable in again and again. This trouble's really exhausting me.

What is the problem?

  • In order to help with this question, I'll need more information. The first question I have is, when you say you are plugging the netbook directly to the cable, do you mean you plugged the cable from your cable or DSL modem in to the netbook, or a wire from the ethernet ports on your router. Also, if you could include the output of the ifconfig command in your question it may be helpful. This will list information about all of your network connections on the netbook and will show if you have a valid IP address. – Dennis VanMeter Dec 5 '10 at 19:54
  • ok comp do you have a stand alone wireless network? You mention pulling the cable out, which sounds to me like you are disconnecting the actual source of your internet, but leaving the wireless intact. – RolandiXor Dec 5 '10 at 20:42
  • 1
    looks like a driver problem to me. Whats your wireless card or chipset if it's integrated? – danizmax Dec 6 '10 at 22:02
  • guys, thanks for your feedbacks. here I will try to tell & make all of you understand what situation I through with. 1) i install the UNE. I updated all the recommended updates manager asked. 2) I am using regular DSL modem, that have cable wire & wifi. 3) problems are, I can surfing the internet only using wire cable & cannot surfing with wireless even though the wifi indicator at my UNE applet tells 100% active – ok comp Dec 7 '10 at 16:20
  • @okcomp: One question that I haven't seen addressed because maybe it's too obvious, but have you tried connecting to another wireless source? Internet cafe, etc.? – Jeff Bauer Dec 20 '10 at 3:39

You haven't indicated which brand your wifi adapter is. Have you check if there's a more uptodate driver for your wifi adapter? Does this also happen if you try it on another platform like windows?

| improve this answer | |
  • everything's going fine if I am using my windows 7 starter – ok comp Dec 20 '10 at 8:08

I suppose your computer doesn't receive LAN paramenters (IP, DNS) via wifi. Try to Ping some IP outside you home network, for example Google public DNS If it works with wifi after disconnecting from your ethernet cable, you probably need to configure your wifi connection settings manually ! Most likely you will need to provide DNS server information.

Wifi manual settings

| improve this answer | |
  • if I using windows 7, my wifi works on it nicely – ok comp Dec 20 '10 at 8:06
  • 1
    It's possible. Different operating systems (software) behave differently :). I noticed, that sometimes it is necessary to provide manual configuration of internet parameters. – Vincenzo Dec 20 '10 at 9:15
  • I agree with pf.me and others who suggest reinstalling of wifi drivers. I remember this kind of problem even in WinXP. A solution in that case was "Repair connection" action. – Vincenzo Dec 22 '10 at 10:10

I had a very similar problem today using Ubuntu Maverick. I reinstalled my wi-fi driver (bcmwl-modaliases) and now the issue is apparently fixed. Identify your wi-fi driver and try to reinstall it on the cable. Then reboot and try to use your wi-fi connection.

| improve this answer | |
  • I already installed and reinstalled it. it doesnt worked at all – ok comp Dec 26 '10 at 16:07

If I were experiencing this type of problem with my own computer, I would start by trying to figure out whether the problem was with the DSL modem/router, or the computer. So the first thing I would do is reboot the modem/router to see if it is just a simple problem with that equipment.

Next, I would log in to the modem/router's web based configuration system (using the wired connection) to reset the wireless password just in case I had mistyped it. Then I would reset the wireless password on the computer to match the password entered into the router's configuration. Then, I'd unplug the ethernet cable and turn on the computers wireless and connect wirelessly to the router. Does it work?

Next, I would start to suspect that maybe it is a problem with the computer. Is there another wireless access point that you can try connecting too? Maybe at a library or coffee shop? If I could not connect successfully to another wireless access point, then I would really start to suspect that the wireless on the computer had some kind of problem. Maybe a driver that doesn't work properly? Maybe the wireless card is defective?

Finally, I would start to investigate what type of wireless card was installed in the computer. Is it well supported in Ubuntu and other Linux based systems? Have other people reported trouble with this type of wireless card? If so, I would look seriously at replacing the wireless card with one that is properly supported by Ubuntu, most are.

| improve this answer | |
  • my modem is not damage and still in good condition and if I am using windows 7, my wifi works on it nicely – ok comp Dec 20 '10 at 8:09

Some questions:

  • Are you using network-manager for managing the wireless NIC (WNIC)?
  • Can you paste the output of ifconfig in your initial post?
  • Can you verify that the WNIC is indeed connected to your wi-fi network?
  • Have you obtained an IP address on your WNIC?
  • If you do have obtained an IP address on the wireless adapter, try 2 things:

    1. Disable the wired NIC (type: sudo ifconfig eth0 down) or
    2. Release the wired NIC's DHCP lease (type: sudo dhclient eth0 -r)
| improve this answer | |

Read through the community documentation here it should give you all the information needed to find the root cause of the problem.

If your still having problems you will need to provide some more diagnostic information to enable us to help you further - stating that it works fine on Win7 gives us very little information to go on.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.