5

I have a logilink PCIe USB3.0 interface in my computer. Unfortunately there are no drivers available at the website of logilink. Is there any possibility to use this interface on ubuntu?

3 Answers 3

6

The VIA VL800 controller used has poor support for Linux

It appears you are using Logilink's 4-port USB 3.0 card:

enter image description here

This uses the VIA VL800 USB 3.0 controller. While this controller fully supports the USB 3.0 standard in theory and should work well with the default xhci USB 3.0 driver in Linux, it does not. In fact, there is a well-documented history of the VL800 not working, [working at low speeds](, crashing your kernel, etc.

This is not Ubuntu/Linux's fault, but the manufacturer's (VIA) for making a poorly-supported non-compliant product.

Solution: try a newer kernel, or use a different Logilink USB 3.0 card with the NEC chipset

You have two options:

  1. You can try a newer (beta) Ubuntu kernel, hoping the that workarounds for the VL800 have been added, thus improving support.

    • But this may cause problems with your other hardware, notably Nvidia/AMD graphics and wireless -- see warnings/general information here
    • If you want to do this, look at this answer for hints, or Google/search AskUbuntu.com on how to install the newer kernels.
  2. Simply get another card with better Linux support

    • Logilink also makes a 2-port PCI-Express USB 3.0 card which uses the NEC USB 3.0 chipset that has excellent support in Linux/Ubuntu (it was the first USB 3.0 chipset to come out and the company played an important role in drafting the USB 3.0 standard).

    enter image description here

    • I would certainly consider replacing your card with this one instead of messing about with mainline/beta kernels.
1
  • First of all thank you very much for your expansive answer. Unfortunately i am using the 2-port-version of this card which works fine on XP but will not even be recognized on the fresh new ubuntu.
    – matt
    Jul 14, 2012 at 8:51
0

You can use NEC chipset, the 3rd generation D720201, and this PCIe to USB 3.0 card with 20pin connector.

1
  • I have a startech.com PEXUSB3S44V, Rev:PCom1 with the D720202. It NEVER worked. And with the latest kernel I can't even boot anymore. Had to remove the card from my PC. This was the most expensive USB pcie card that I could find at the time I bought it (due to other usb3 problems). Bottom line is: linux and USB3 don't work very well - and I'd certain stay far far away from the D7202* chipset!
    – Carlo Wood
    Feb 21, 2022 at 15:08
0

I had the same problem and more...

I had a "xHCI Root Hub" not recognized in my Device Manager and it caused problems even on my USB 2.0 ports.

My specific problematic card was the "TECKNET "Eu308d" USB 3.0, 5 ports PCI-E Expansion Card".

After hours of researches, tens of attempts of different kinds: updates of my Intel DZ77GA-70K motherboard, USB drivers, Windows ans system diagnosis tools and much more, "ORICO "PVU3-5O2I-V1" USB 3.0, 5 ports PCI-E Expansion Card" saved my life !

Marvell USB drivers didn't worked. Neither Fresco, Prolific, NEC, Renesas or others.

Finally, an attempt with the "http://drive.orico.cc/ORICO-PVU3_Series_Driver_V4.90A_AP.zip" solved the problem instantly...

In fact, it contains VIA Lab's USB 3.0 chips host controller drivers THAT WERE NOT INCLUDED with my damn TECKNET USB 3.0 expansion card... That was the real problem origin...

Hope this can help !!!

Good luck.

P. Dauphin Quebec, Canada

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .