I see that there are some other threads that mention this error, but I have tried the solutions with no luck.

When I log into my 12.04 Server, I get the message:

/dev/sdb1 will be checked for errors at next reboot
/dev/sdc1 will be checked for errors at next reboot

The problem is that the check is never done and I continue to get the messages. I ran a fsck on both drives and they are fine.

  • I just rebooted again and didn't get the warning...
    – dpbklyn
    Commented Jul 13, 2012 at 14:46
  • I tried a suggestion to do touch /forcefsck and reboot, but I'm still getting this warning.
    – pcm
    Commented Sep 5, 2012 at 20:40
  • See if this helps you: askubuntu.com/questions/60249/…
    – Takkat
    Commented Feb 5, 2013 at 7:30
  • The message in the message of the day (motd) about drives being checked doesn't go away even when the drives have been checked. This is a known bug in Ubuntu. This is caused because that message is cached in the file /var/lib/update-notifier/fsck-at-reboot so that it is not constantly recomputed. /usr/lib/update-notifier/update-motd-fsck-at-reboot checks the timestamp on the file and is supposed to regenerate it every so often. However, there is a bug and the timestamp gets set in such a way that it never regenerate Commented Apr 20, 2013 at 10:12
  • I have a similar warning on Ubuntu 14.04.1: *** /dev/xvda1 should be checked for errors *** No bad blocks. Log shows everything OK. Is this the same bug?
    – plamtrue
    Commented Jan 19, 2015 at 21:40

3 Answers 3


This is a known bug in Ubuntu 11.04 and apparently still exists in 12.04 LTS. What happens is what you described: you keep getting the notification even though there is nothing wrong with your hard drive and no checks are scheduled/will be done.

It's caused by the /usr/lib/update-notifier/update-motd-fsck-at-reboot script generating a /var/lib/update-notifier/fsck-at-reboot file with a timestamp in the future. The previous link has a convoluted solution from one of the Ubuntu maintainers (Steve Langasek), but it may be simplest to just do this:

  1. Open a terminal with Ctrl-Alt-T
  2. Type:

    sudo rm /var/lib/update-notifier/fsck-at-reboot
  3. Exit the terminal and reboot (or logout/login).
  • In my case editing the file and removing the text resolved the problem. When I tried removed it at next login it would simply recreate the file so it the problem would persist. Commented Feb 14, 2014 at 10:54
  • 1
    Here a command that will fix the problem without any sort of reboot or logout: sudo bash -c 'rm /var/lib/update-notifier/fsck-at-reboot && for file in /etc/update-motd.d/*; do $file; done > /var/run/motd' && cat /etc/motd Commented May 9, 2014 at 19:24
  • 1
    Still a problem on 14.04 but this solution didn't fix anything.
    – Ron Smith
    Commented Sep 7, 2015 at 20:36
cat /dev/null > /var/lib/update-notifier/fsck-at-reboot

Fixed this for me....

Ubuntu 12.04.2 LTS.

3.2.0-51-generic #77-Ubuntu SMP Wed Jul 24 20:18:19 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
  • 1
    Yeah, when I did rm fsck-at-reboot, it was recreated when I logged in again. So I had to edit fsck-at-reboot to delete the message. (This was for an AWS EC2 Ubuntu 13 machine)
    – wisbucky
    Commented Oct 21, 2013 at 23:46
  • Same here, editing it instead of removing resolved the problem. Thanks. Commented Feb 14, 2014 at 10:52

I had this same problem today - turned out in my /etc/fstab file, the line that had the relevant filesystem, had "0" in the last field, which means don't fsck it on boot. This should have been "1" for the root filesystem, or "2" for any other filesystem.

Also, my motd wasn't updated after the (successful) fsck. You can use this command:

tune2fs -l /dev/something

Then look for a line that says "Last Checked".

  • This is quite helpful. Commented Feb 7, 2013 at 16:41
  • I'm not sure you need to change fstab. I think this is managed elsewhere.
    – beruic
    Commented Feb 13, 2013 at 23:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .