Disabled a standard user account but did not opt to delete files. Later, tried to enable the account. At that time, a password had to be selected so entered a different one from the earlier one. Now, at the log-in screen the user account appears but cannot log in using the new password or the old password. Tried many tricks but still could not let the user log into the account.

The tricks:

  1. Tried to find some command in 'lightdm' package to modify the user account. Couldn't solve the problem. {Ex. /etc/lightdm/lightdm.conf}

  2. Removed the package 'apparmor' suspecting it is causing the problem. It didn't solve the problem.

  3. Installed some packages from Synaptic, relevant to user accounts. No luck.

  4. Browsed in system folders such as 'var', 'etc', 'bin', 'root' and many others, to find a clue so that the user account can be re-enabled. No way!

  5. From System Settings, selected auto log-in without password. Even then the user still can't log in.

Runnng sudo passwd USERNAME in terminal takes me to the log in screen. Hope these details would be of help. Still trying to solve the issue.

Well, finally I decided to delete that user and recreate a new user account with a slightly different name. Most files which had been backed up could be restored, although some were lost. All users should be asked to back up whatever files which are important using a tool such as Deja Dup. So in case of an issue like this, even if the user account gets deleted one can still recover the files.

  • When you say sudo passwd USERNAME takes you to the login screen, what do you mean? Do you mean that when you run that, a graphical login screen immediately comes up? Or that you are immediately logged out and see the text-based login screen? Or something else? Are you running this in a Terminal window or in a text-based virtual console? Jul 14, 2012 at 12:56
  • Yes it happened once or twice, while trying certain commands to see what the result would be. Later, when commands were entered, Terminal gave a message [ex. password for user 'xxx' was updated]. However with that new password (even after a reboot) user cannot log in.
    – askadink
    Jul 15, 2012 at 12:02
  • I still don't know what you mean. What is it that "happened once or twice"? Jul 15, 2012 at 15:45
  • In the process of trying various remedies, at one stage, it so happened that when selecting the password and user, the terminal directed me to log-in box of the user. This behavious changed later with other steps being taken to tackle the issue.
    – askadink
    Jul 20, 2012 at 9:17

2 Answers 2


You said you "tried many tricks." What did you try, exactly?

Did you try changing the user's password with sudo passwd USERNAME? That will usually solve this sort of problem.

(If that doesn't fix it, please edit your question to add details about what you've done.)


I think your user account is corrupted. :)

If you don't have any valuable data in that user account then you can simply delete it bby typing

sudo userdel -r [username]

After that create a new user from your account.

Let me know if its solve the problem.

  • hmm, why should he create a new user account. After sudo userdel -r [username] he should be able to login into his old accoung.
    – gemue2010
    Jul 14, 2012 at 3:20
  • askadink says "Of course there are some valuable data in that account." (That was originally an edit, but that is not an appropriate edit--edits should not be used to respond to a post--so I've rolled it back and provided the information here in a comment.) @gemue2010 userdel deletes the account. One cannot log into a nonexistent account, without re-creating it first. Jul 15, 2012 at 15:39
  • Most of the important documents which were possible to be copied other drives/folders were saved. Some were lost. The remedial action taken by me was to delete that account completely and re-create another one (with a slight change of name). Backed up files, Tomboy Notes and files stored in Ubuntu One could be recovered.
    – askadink
    Jul 20, 2012 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.