I just bought a new Toshiba system, and before installing Ubuntu, I tried it out on a live CD. Unfortunately, Ubuntu doesn't recognize any wireless adapter.

$ sudo lshw -c network
  *-network UNCLAIMED     
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: ioport:3000(size=256) memory:c2400000-c2403fff

From the above output, I think that my Realtek wireless chip is unrecognized as what it is. But in my experience, all the Realtek devices worked out of the box. Furthermore, regardless of the manufacturer even if the appropriate drivers were not available, at least the devices were recognized for what it is properly.

Additional Drivers does not detect any proprietary drivers for me to install. (I have yet to install Ubuntu, and ran Additional Drivers after updating repository lists)

Wireless works on Windows 7 after installing necessary drivers. That is to say, there is no problem with the hardware, I'm befuddled why the hardware is not recognized at all (refer to the lshw output above). As far as I am aware, even hardwares requiring proprietary drivers to function would at least be recognized in lshw output and such.

lspci -nn | grep Network shows:

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:8723]

4 Answers 4


Ubuntu 13.04 and newer

As of 13.04, the driver need not be compiled and installed separately, and comes integrated with the kernel as the rest of the drivers.

12.10 and older

Congratulations, you have the super-brand-new RTL8723AE-BT card!

As far as I am aware, even hardware requiring proprietary drivers to function would at least be recognized in lshw output and such.

Yes, unless the hardware is so new that it's not even in the lshw database yet :)

The only recent wifi card I know of that causes such havoc is the Realtek RTL8723AE-BT. It's so new that even the Realtek website does not mention it or make Windows drivers available (must be downloaded from Toshiba/OEM). You can verify with the -numeric switch to lshw that the last 4 digits of the product (PCI) ID are 8723:

sudo lshw -C network -numeric

This is also supported by the DriverIdentifier listing for your laptop model and the official specifications of the C850-A965:

enter image description here enter image description here

However, Realtek Support has made their internal driver available via Dropbox (for now) and it seems to work well on 12.04 as well as other recent Linux distros.

Steps to download, build and install RTL8273AE-BT driver:

Note: I'm not sure how well this will work on a live CD, since a reboot is typically a good idea after installing new kernel modules. But it should work on an installed system (don't forget to upgrade to the latest kernel on that first though!)

Open a terminal, and type/paste one line at a time:

sudo apt-get update
sudo apt-get install build-essential linux-headers-generic linux-headers-`uname -r`
wget -O- http://dl.dropbox.com/u/57056576/DRIVERS/REALTEK/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012.tar.gz | tar -xz
cd rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/
sudo make install
sudo modprobe rtl8723e

The Ubuntu LiveCD should detect the wifi-card now, and in a few seconds you'll be able to choose the network to connect to. In that case, later on, you can delete the rtl_92ce... folder created in your home directory.

  • @Oxwivi: very glad to know it works (as I expected). The source of the file is Realtek techsupport -- multiple posters have said that if you email them, they send you this link. A listing of the contents shows that it appears to be what is claims to be; I compared it with my attempt at modifying the publicly available driver in the last question before answering your question to make sure it is (similar structure). Also: the modprobe is only necessary on LiveCD; after reboot on a system it's automatic.
    – ish
    Jul 17, 2012 at 7:22
  • make install will be enough? That's great. If all Linux drivers are as straight forward (straight forward to command line users, that is) to upgrade, then it isn't so painful as I've heard it to be. Thank you very much for all the help, really thank you. Bounty can only be awarded after 8 more hours though.
    – Oxwivi
    Jul 17, 2012 at 7:32
  • @Oxwivi: sudo make install :) As for ease of upgrading, Realtek is generally fairly painless (can't say that for all, especially ones that don't open-source like Broadcom). I expect they (Realtek/kernel team) will put the 8273 driver in the kernel soon, meaning it will be built-in Ubuntu in the next few months, making this whole procedure unnecessary. You're very welcome; whenever you can get to the bounty is fine, no hurry; in the meanwhile, if you have any other questions please feel free to ask. Enjoy the new laptop!
    – ish
    Jul 17, 2012 at 7:41
  • 1
    Thanks for letting me ask, I was afraid I was getting too talkative and spamming comments to your annoyance. From the Dropbox situation, I'm assuming it isn't stable enough for publishing on driver website, let alone the kernel. I don't expect it to be in the kernel until the next LTS point release either. Would you mind updating me if the driver is properly published and updated (or at least point me to the tech support thread), and I how I can upgrade the driver?
    – Oxwivi
    Jul 17, 2012 at 11:06
  • @Oxwivi: no, the driver appears to be stable to me -- see part of readme. I think there's other reasons behind why not even the Windows drivers have been published and are available from OEMs only (and the product is still missing from their website). I'll keep an eye on it, and ping you from this answer if/when the driver makes it onto their website/FTP.
    – ish
    Jul 18, 2012 at 8:27

Wired connections work out of the box. For wireless connections you need proprietary drivers for your wireless card. You can download it by connecting your laptop to internet via a wired connection and then install drivers via additional drivers application. Then you can use wireless connections.

  • 2
    Not all wireless cards need proprietary drivers to work. Jul 13, 2012 at 16:40
  • Yep, wired worked out of the box, but what I'm more worried about is that the device didn't get recognized at all. I'll try running the Additional Drivers to see if any is offered.
    – Oxwivi
    Jul 14, 2012 at 11:09

First, check the security settings for the router. If it worked before, it should. Change it until it works.

If it still doesn't work, complete the Ubuntu install without Internet connection

Then install the latest Drivers from the RealTek Website or install Ndiswrapper. More info about Ndiswrapper can be found here.

  • It never worked before, it's new laptop. :)
    – Oxwivi
    Jul 17, 2012 at 6:37
  • You said that before, all RealTek devices worked. Jul 17, 2012 at 10:32
  • All Realtek devices worked before in my experience. I wasn't referring to this laptop.
    – Oxwivi
    Jul 17, 2012 at 10:55

This problem is solved in this topic http://ubuntuforums.org/showthread.php?t=2017622

  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Jan 7, 2013 at 19:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .