I had dual screen working previously. Now every time I try to setup dual screens and reboot. I get logged in as tty mode, i am able to get one screen working, or have my desktop span both screen ( one huge screen) what i require is two independent screens, that I can drag windows between.

This is frustrating, i am sure you can imagine. This issue now is whether or not xorg.conf is used anymore. from my understanding isn't.

I would appreciate any help that you guys provide in solving this issue.


Edit: Here is my xorg.conf generated by the nvidia-settings command, when i select separate screens.


  1. Get it working with one screen on the nvidia driver?
  2. Run gksu nvidia-settings and under the screen configuration part, get both screens working.
  3. Click the Save X Configuration File button on that same page. This is why you need to run nvidia-settings as root.

Then when you reboot, it should remember your settings.

| improve this answer | |
  • i do that every time i think the xorg.conf is messed up. I pasted it above mind taking a quick look. – myusuf3 Dec 6 '10 at 0:32
  • btw, I cant get both screen working from the settings. it says i require a restart of x, and if just restart that it doesn't do anything. What should i do next? – myusuf3 Dec 6 '10 at 0:56
  • That X config is very odd. Why isn't twinview enabled for starters? – Oli Dec 6 '10 at 1:48

I just upgraded to Ubuntu 11.10, and no dual view anymore.. I tried everything above, but no help.. Finally, I was brave, and in the menu System Tools -> System Settings, I clicked on "Additional Drivers" (under Hardware), and installed 'version current-updates' instead of 'version 173-updates'. After a reboot, I had version 280.13. And finally, in menu Other -> NVIDIA X Server Settings, the "X Server Display Configuration" was correct. And I could select and configure the 2nd display.

| improve this answer | |

Maybe these links could be of some help:



If not, could you paste your xorg.conf here?

| improve this answer | |
  • done and done no mas. pasted the xorg.conf above. – myusuf3 Dec 6 '10 at 0:53

I just reinstalled the drivers and selected twin view and it managed to work.

| improve this answer | |

When this sort of thing happens I generally

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

and then do nvidia-settings if I'm using the nvidia settings or dpkg-reconfigure xserver-xorg otherwise.

If there is no existing xorg.conf these programs will automagically generate a new one. Sometimes this solves problems, sometimes it creates them; but having the old and new versions of xorg.conf to diff can be instructive for troubleshooting.

| improve this answer | |

Which nvidia package on your system is installed?

On my Natty I have nvidia-173 installed - because I own an old GeForce FX 5200. After selecting "Separate X Server" by enabling TV-Out in nvidia-settings and restarting my X-Server never came up.

After looking around I found out that nvidia-settings wrote a defect BusID into my xorg.conf. I fixed it by doing:

  1. sudo lspci | grep VGA

    • I got out: 01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
  2. replacing BusID "?@?:?:?" with BUSID "PCI:1:0:0"

  3. service gdm restart :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.