I've done a clean install of Ubuntu 12.04 from a liveCD on a Samsung Series 7 Chronos with a 3rd Gen i7 and the Nvidia GeForce GT 640M.

I've followed this: (https://wiki.ubuntu.com/Bumblebee#Installation) to install bumblebee so I can switch to my discrete GPU. I have not used ironhide, or preivous bumblee since it's a clean install.

When I use optirun, optirun says it can't initialize the GPU:

[ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[ERROR]Aborting because fallback start is disabled.

I've looked at the troubleshooting page for bumblebee and I have the correct driver and do not think I have aspci disabled.

Also, my keyboard becomes very unresponsive and my mouse skips and isn't smooth after optirun crashes. The only thing to fix this is a reboot.

Here's my lspci | grep VGA output:

00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fd2 (rev ff)

It seems Ubuntu can see my graphics card. I don't really know what's going on.

  • I have the same laptop, nice machine, have you solved your problem in the mean time? What kind of driver do you use now? – 0x4a6f4672 Dec 13 '12 at 20:45

From the Bumblebee Troubleshooting webpage

Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please ...

PCI:1:0:0 may vary, but take a look at the last lines of the kernel log (usually located at /var/log/kern.log, /var/log/kernel or /var/log/messages). You're probably using an outdated driver or messed a bit with improper ACPI calls (see above).

If you've already been over that, then you will need to file a bug report with the bumblebee project, so that they can help diagnose your problem.


This issue is already reported in the Bumblebee issue list #172:

GT650M: Failed to initialize NVIDIA GPU


I have the same issuse with my Dell Inspiron 17R-SE (Ivy bridge i7, GT 650M). I tried different nvidia drivers (259.59, 302.17, 304.22, with the same failure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.