8

Rebooted my PC today to find that my launcher icons are not showing on the launcher bar, even though they are still there. I can hover over the launcher bar and see (via the mouse tool-tip) that they are still there, and I can even interact with them. I cannot, however, see them even after doing the following:

9

Have you tried unity --reset-icons?

It's best to run this kind commands from tty1. Press Ctrl+Alt+f1, log in and then enter these commands:

unity --reset-icons
unity --reset
reboot
  • I don't know which of the two additions made the difference (running --reset-icons and using tty1. Either way, it fixed the problem. Thanks! – Carey Head Jul 12 '12 at 19:53
  • FYI, for me, rebooting fix this problem for a while, then it kept coming back. unity --reset-icons worked for me only after upgrading the unity package using sudo apt-get update; sudo apt-get install unity, and thankfully it didn't require a reboot. Crossing my fingers this fixes it for good. – Jeff Ward Dec 10 '13 at 16:28
3

The disappearing icons problem is described in bug #806248. You should mark the bug as affecting you.

  • Thanks, my uptime of "25 days, 22 min" would seem to indicate that this is the bug that I'm experiencing. – Abe Voelker Dec 14 '12 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.