The Lenovo Z560 Ideapad has a row of 4 led buttons in the top right corner of the keyboard. The button on the left end of this group is the speaker mute/unmute button. Usually, this light is either on or off to indicate the sound being muted or unmuted. This is how it works while the laptop is plugged in to an electrical outlet.

However, when running on battery, the light remains off when the sound is muted, but it constantly blinks when the sound is unmuted. The blinking is somewhat distracting. Is there any way I can make the led behave the same way when running on battery as it does when plugged in? Any system file I can edit? All I want is for the light to always remain in either a constant on or constant off state. Blinking on and off gets distracting.

  • I am also having exactly the same problem. I am using HP pavilion dv6000. – Sabya Jul 17 '12 at 2:35

I think I found the solution to the problem. See this thread:


It looks like the issue has nothing to do with Ubuntu or the kernel and is related to the Pepper-based Adobe Flash built in to Google Chrome. When I followed the instructions given in that thread and disabled the Pepper Flash to use only the normal Flash (the one Adobe is going to discontinue for Linux, sadly....), the problem with my blinking led goes away.

(Note that in the linked thread, the problem was the webcam light blinking, and here it was the volume mute button blinking, but in both cases the same fix worked)

The fix listed in the thread is as follows:

Go into about:plugins, hit +Details to expand, then disable the "/home/opt/google/chrome/PepperFlash/libpepflashplayer.so" plugin, while leaving the normal flash enabled

(also not that this only affects Chrome, not Chromium (or Firefox), since only Chrome uses the Pepper-based Flash)


Had teh problem of the touch buttons constantly going on and off and making it impossible to work with the laptop. Finally resolved it by disconnecting the touch panel entirely. Steps involved.. First you need to lift up the keypad by prying it up. See youtube for video. Next just disconnect the right most ribbon connector which is the one for the touch panel. Now press teh keypad into place. Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.