For the last three days I have been trying to install Ubuntu 12.04 LTS on a Kingston DataTraveler Micro 16GB USB pendrive (to be called the install USB). The processor is a brand new Intel Atom D525 (computer is brand new). It is a regular full install (so I am not trying to create a live USB) using the regular desktop installer run from another USB pendrive (to be called the live USB) which runs the Desktop 12.04 ISO. I want to use this install USB as a default for booting, no other drives are connected.

I followed all steps from: How can I run Ubuntu without a hard drive? and from Method 1 of: https://wiki.ubuntu.com/LiveUsbPendrivePersistent/. So basically I created a new MBR on the USB pendrive with two partitions (EXT2 mounted on / and 2GB swap). I have installed the bootloader (GRUB) on the /dev/sda (I actually also tried /dev/sda1 just to see whether that would work...) which is the install USB (the live USB is /dev/sdb). Everything seemed to work perfectly fine (live USB boots/works perfectly).

However, when booting from the install USB I am confronted with the GRUB prompt instead of a menu or Ubuntu booting. No message whatsoever, just the prompt. This happens everytime I try to install. Entering commands in the GRUB prompt such as "ls" all end in an error: "hd0 read error" or "no such partition".

I have already tried these options:

  • Install on /dev/sda1 instead of /dev/sda (obviously does not work, had to try)
  • Install using EXT4 instead of EXT2 (same result, as expected)
  • Reinstall GRUB using Boot-repair (same result)
  • Reinstall GRUB from commandline (same result)
  • Two complete reinstalls using a brand new Ubuntu Desktop ISO and different tools to create the live USB pendrive (hash checked) (takes ~2 hours per install including updates...)

My guts tell me that somehow GRUB2 is incompatible with reading from the pendrive (again, live USB boots fine, but I think that uses a different bootloader).

I would like to use the install USB as a default boot drive (as the computer is going to be online 24/7 so a slow boot is not a problem and it should work...). I hope my problem is clear and that someone could help me out. I already tried Googling and asking for help on the IRC channel, but no result (the guy did not know what was going on either and suggesting posting here). I would very much appreciate any help as I am basically out of options.

  • From bios menu have you set the booting order to Usb Drive as default .It also provides an option of booting from drive you mention there. – atenz Jul 12 '12 at 12:15
  • I have already done that, otherwise GRUB would not be shown at all. This is not the problem I described. – PatPets Jul 12 '12 at 12:16
  • From the other Pen Drive which you are installing from , Format this 16 gb drive to required formats using gparted , and select the BOOTABLE flag from gparted to this 16 gb drive. – atenz Jul 12 '12 at 12:19
  • possible duplicate of How do I install Ubuntu to a USB key? – Takkat Jul 12 '12 at 12:20
  • As I stated, the 16GB drive is formatted into two partitions namely EXT2 mounted on / and swap. The BOOTABLE flag has already been set to the first partition. – PatPets Jul 12 '12 at 12:22

Maybe you already did that, but be sure to rename all isolinux* file to syslinux* on the pendrive, as explained in the Unetbootin section of this guide. One time I had a similar problem and I was missing this part.

|improve this answer|||||
  • Well the live USB is not the problem. As I stated before, that works fine actually. It is also not a live USB I am trying to make, but a Regular Full Install on the USB pendrive. So that guide does not have anything to do with my problem. – PatPets Jul 12 '12 at 12:07

Have you changed the location of your USB pendrive in the /boot/grub/grub.cfg file? This location could change according to the connected USB device at the time of the installation.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.