10

When creating a boot-able USB or LiveUSB with Startup Disk creator in Ubuntu 12.04, the following error message appears:

Installation Failed
An uncaught exception was raised: Invalid version string 'GNU/LINUX'

What does this mean? Is there a fix for this?

4
  • Try running the Startup Disk Creator like so: usb-creator --allow-system-internal Be sure to select your USB key from the drive list, and not your system drive. This seems to be a documented bug.
    – SirCharlo
    Jul 12 '12 at 13:10
  • If you start a terminal with Ctl-Alt-T what is the output of the lsb_release -a command? Jul 13 '12 at 5:07
  • It is quite long, it starts with this LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx- ... and ends with Distributor ID: Ubuntu Description: Ubuntu 11.04 Release: 11.04 Codename: natty
    – Peachy
    Jul 13 '12 at 8:00
  • Were you trying to make a Ubuntu starup disk, or another OS (GNU/LINUX)? May 7 '14 at 16:52
7

Actually, this is not the documented bug mentioned by @SirCharlo. In fact, it's not really a bug at all. Startup Disk Creator is designed to only make Ubuntu startup disks. If you read the description of the program, it does actually say this, as I found out after the fact.

In my case, I was trying to make a Debian startup disk, and it has an OS Version labled "Debian GNU/Linux...", and therefore the app will not use it to make the disk. Making a Ubuntu disk works perfectly.

It would be nice if it gave a better error message, but the behavior is evidently by design.

2
  • I confirm this, I had exactly the same error (trying to create Debian Jessie startup disk). The message is really misleading. Apr 26 '15 at 14:47
  • I use tuxboot or UNetbootin now to create USB disks. Worked fine for Debian Jessie, which I tried out today (and which makes me appreciate how easy Ubuntu is!). Apr 26 '15 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.