I am on 12.04 using ubuntuone-client 3.0.1-0ubuntu1.0.1. I actually have two machines that I sync with, having the same Ubuntu version and ubuntuone-client version. One is fine, the other is not.

File sync has frozen within a user-defined folder under my home folder. The graphical client reports in the top-right corner: 'File Sync starting...', but this doesn't change. I have two files with changes that show a syncing overlay in Nautilus. They are both very small text files.

Here are some details:

harb@joan:~$ u1sdtool --status
State: READY
    connection: With User Not Network
    description: ready to connect
    is_connected: False
    is_error: False
    is_online: False
    queues: WORKING

harb@joan:~$ u1sdtool --current-transfers
Current uploads: 0
Current downloads: 0

The status seems to suggest that I am not connected to a network, however I am connected to a network - in fact I am accessing this machine via NX. Is it not working because I am connected via NX?

Happy to provide other info, just not sure what would be useful.

  • 1
    Having the same issue and I have upgraded to 12.10 – bakytn Sep 29 '12 at 11:39
  • This also worked for me. I had been using U1 in headless mode and when I installed FreeNX NX server on the machine, U1 stopped working and gave me this " With User Not Network" message. I disabled the network manager, as described above and things are no going fine. – David Wiczer Feb 26 '14 at 19:30

I was having the same problem after just upgrading to 12.10 from 12.04 and it turned out that something in the upgrade (presumably) had re-enabled NetworkManager (which I don't use) so U1 was waiting for NM to tell it that the network is connected.

Problem solved once I disabled NetworkManager (again!) using instructions found in the community documentation:

sudo stop network-manager
echo "manual" | sudo tee /etc/init/network-manager.override

NB: You probably don't want to just "try" those commands unless you are sure that this is your problem (e.g. if you configure your network manually via /etc/network/interfaces file instead of the desktop interface).

I do suspect this is indeed the OPs problem with his NX server.

  • Thanks @Will, I'll give it a go. What do you use to manage your network connections if not NM? – a different ben Nov 3 '12 at 23:49
  • @adifferentben I don't really "manage" them, I defined them manually the old-fashioned way in /etc/network/interfaces and they stay the same (I have some things set up like bridge interface and ipv6 tunnel that is difficult to deal with using NM). Probably your NX server is set up like that also (servers often are) so be sure to disable NM only on the server, not on your client. – Will Daniels Nov 7 '12 at 4:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.