I just returned from a two-week vacation and started up my laptop, everything went fine and it installed a lot of updates (including a kernel update. sorry for few details, I didn't really pay attention to what it did update).

The next time I tried to start up the machine, it wouldn't. Among the last messages there was e4rat, and when the automatic package repair (in ubuntu-repair-mode or whatever it's called in English - fortunately, that works) wanted to replace it with ureadahead, I figured there'd be some kind of incompatibility with the newest kernel.

So I removed it myself (as the automatic repair wasn't able to. Did it using sudo apt-get install ureadahead ubuntu-minimal , which worked fine), and manually removed the e4rat-preload-line in grub.

Problem is: It won't show the login-screen but instead it switches to tty1, prompting me to log in. When looking at tty7, it only shows me the usual startup-messages of what was started last (no error messages visible).

Running sudo service lightdm (re)start freezes the entire system, same when trying to run gdm. According to the xorg.log file, fglrx works fine (no error messages).

/var/log/lightdm/lightdm.log states:

[+0.16s] DEBUG: Launching process 1257: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none


[+0.73s] DEBUG: Process 1257 exited with return value 127 [+0.73s] DEBUG: X server stopped

/var/log/lightdm/x-0.log states:

(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found

/usr/bin/X: symbol lookup error: /usr/lib/xorg/modules/drivers/fglrx_drv.so: undefined symbol: GlxInitVisuals2D

I already deleted (after backing it up) the xorg.conf file to avoid misconfiguration.

Edit: /var/log/syslog states:

Jul 12 16:22:29 Lutz kernel: [ 24.014008] init: lightdm main process (1213) terminated with status 1

Any ideas?

Thank you in advance.

  • Forgot to mention, I'm running Ubuntu 12.04 LTS!
    – Lutz vdB
    Jul 12, 2012 at 8:49
  • Did some more research, the fglrx driver I'm using seems fine according to the xorg log file (no error messages).
    – Lutz vdB
    Jul 12, 2012 at 9:03
  • Thanks for researching the problem before asking. Also, thanks for all of the detail you gave. :-)
    – nanofarad
    Jul 12, 2012 at 16:51

2 Answers 2


It looks like your Login Manager does not load up. Can you verify this with:

# ps aux | grep lightdm

If it only outputs the grep itself then LightDM is not running. You could try:

# service lightdm restart

If you are using lightdm of course, in Gnome this is GDM, KDE uses KDM, LXDE uses LXDM. etc..

Also if this continues to occur you should do a:

# runlevel

and see it the init level is the right value, I believe it is supposed to be 2 or higher at least.

I hope this helps steer you in the right direction.

Kind regards, Jochen

  • Thank you for your support. Unfortunately, lightdm seems to be started up, and restarting it freezes the entire system (complete freeze). Run level returns N 2.
    – Lutz vdB
    Jul 12, 2012 at 11:37
  • I found out some more. See above for the info.
    – Lutz vdB
    Jul 12, 2012 at 14:47
  • Does it literally freeze your entire system or does the screen simply go black? Since if there is an issue with your Video-Card drivers it might be that X no longer functions properly. Jul 16, 2012 at 8:44
  • Nevermind, just saw you fixed it. Happy to hear that. I have had such an issue as well in the past. Jul 16, 2012 at 8:45

I solved it.

The problem was that I installed fglrx manually (not using the official repositories, but via direct download from AMD) and that some update was incompatible to my older version of fglrx. So using a USB thumb drive ubuntu, I downloaded the newest fglrx-driver and installed it from shell; everything's working fine again now.

All help appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.