23

Have you observed that google-chrome has approximately 29 shortcuts. ( Ctrl+A...Z ) I really hate these things. Anyway, my questions:

  • How can I disable some of the shortcuts ?
  • Are there any files where all settings are stored? If there are, where are those files in Ubuntu 12.04?
  • 2
    I hate them too! Ctrl+Intro sends a form, Ctrl+R reloads the page! A point with no return when you're writing fast and hit them accidentally! – Ivan Ferrer Villa Jun 23 '17 at 14:06
9

Apparently in chrome , google has not addressed the Disabling Keyboard Shortcuts Feature yet .

Such applications specific shortcuts are stored by the application, i guess such Shortcut config File doesn't exist in Ubuntu.

There are extensions like Hotkey and shortcut manager which provides User Defined shortcuts though.

Even HUD seems to have limited features in Chrome.

Through shortcut manager , you can disable all the Ctrl shortcuts individually as here.

enter image description here

For further reference visit

Change/Disable Chrome Keyboard shortcuts

Disable shortcuts in Google Chrome

  • 2
    No option to disable Ctrl+W :( – Anwar Aug 2 '15 at 14:03
  • I often use Alt + 1, 3, 7 to write "ë". When NumLock is off by mistake this changes to Alt + End, PgDn, Home, and Alt + Home is the shortcut for home page, which means I lose the text I was writing. Your solution worked for me by modifying the shortcut, using the extension, to rather execute this JavaScript: "return false;" Hope it helps. – that0th3rGuy Jul 11 '16 at 13:14
12
  1. Go to chrome://extensions
  2. In the very bottom right, click keyboard shortcuts Keyboard shortcuts
  3. Rebind Ctrl + Shift + Q to something less annoying. In my case I bound it to open lastpass extension.
2

This is an awful kludge:

Websites' Javascript can intercept most browser shortcuts. This is normally used to implement keyboard shortcuts in web apps (so e.g. Ctrl-S saves the document open in a web app instead of opening the browser's save page dialog). However, if you handle the event by ignoring it, it effectively disables the browser's shortcut.

To do this, create a script that traps all browser shortcuts and discards them. Save it as a Greasemonkey user script (name it something.user.js) and set it to execute on all pages. You can use Chromium's built-in Greasemonkey support, or use any of various extensions if you prefer a different interface. The end result is that whenever you're on any web page (i.e. always), the script will have executed, causing most browser shortcuts to be trapped and discarded before the browser processes them.

Of course, you can write your script to not trap a particular shortcut that you actually use.

Note that there are a few shortcuts (generally related to navigating between tabs) that by design web pages are not allowed to trap. Those will therefore not be disabled.

1

Manhandle shortcuts in Chrome browser, a guide for the perplexed:

TLDR: your solution is in phase 3 of 4 below, install that Chrome plugin.

It's infuriating to have to deal with Chrome's constantly changing keystroke ideologies that continue to randomize every 3 to 9 months. So understanding the four different areas you can put middle-men in the keyboard-to-browser command chain helps you find a solution that works for you, and never changes, for all time, even as you change operating systems, keyboards, and programs.

If you're here, you're having trouble making Chrome behave the way you want. Take a minute and understand the four remapping areas between your computer keyboard's emitted keys, and the client side webpage rendered by the Chrome browser, with 3rd party corporations fighting to change your keys to what they want them to be.

Mac, Windows and Linux are different in their own ways, but they share a common ancestor, and are all the same in way I describe. If you mess around with this process, you have to be careful and take ownership of this assembly line, or else it's easy to leave keys orphaned, cause duplicated actions, even causing multiple actions from one keystroke, key-feedback loops are a pain.

Key remapping area 1 of 4, ( Keyboard KeyCode --> Operating System )

Only Mac and Linux can experiment here. There are programs such as .inputrc and other config files that intercept keys from the keyboard even before the operating system has a chance to hear them. I generally leave this alone since for the most part my keyboard is a faithful transmitter of keys and my operating system is a faithful hearer of keys. You can remap keys here, and change what your operating system hears, thus leaving the Chrome browser powerless to countermand you.

Key remapping area 2 of 4, (Operating System --> Chromium Application )

The Chrome Browser is just a computer program running on your operating system. The OS quarantines the browser window and Chrome only receives those KeyCodes transmitted to it by the operating system. Mac, Windows and Linux all have their own Key-remapping programs, For example Mac's Spectacle and Karabener, or Windows StickyKeys, or Linux's low level internals like .inputrc and config files.

Messing around here involves installing the program for your OS and intercepts the OS keycodes and changes what keys are heard by which application. This remapping area also leaves the meddlesome Chrome developers powerless to countermand you, because they are quarantined to the application space. Install your program and tell it to Remap Ctrl-K to Ctrl-Shift-carpal-tunnel-p and you're off to the races. If you do this, you also need to take heed that remapping area 3-of-4 and 4-of-4 also propagate the key correctly.

Key remapping area 3 of 4, ( Chrome application --> All Rendered Webpages)

This is where your problem is. Those plucky Google-Chrome developers sitting in their crystal fortress constantly change up these keys every 3 to 9 months, because of users yelling at them. This is where everyone can use the Chrome Plugin, regardless of OS: Mac, Windows, Linux. Install the Chrome plugin: Shortkeys (Custom Keyboard Shortcuts) by: Mike Crittenden. This plugin has two areas that let you remap keys in areas 3-of-4 and areas 4-of-4. Read the manual and you can unmap and remap all commands here.

Key remapping area 4 of 4, ( Chrome's V8 Interpreter engine < -- > javascript/jquery/Flash/etc)

This area is where even more problems happen. Those plucky individual and corporate developers all over the world program serverside and client side javascript to instruct Chrome to re-remap your key to what they want it to be. So assuming you correctly transmit your key from areas 1 through 3, Area 4 here countermands you at the last mile.

The ShortKeys plugin has an area for this space as well but you have to make sure area 3 is right. For me just the one chrome plugin does everything I need to counter-mand both the Chrome developers and webpage developers, but it's not perfect. You'll load up a flash app, and suddenly Flash is painting Unicode piles-of-poo and unicorns on the screen rather than scrolling down, as you instructed.

Extra notes:

If you set a remap a key in one area, but not the others, you're left with either a non-remapped key, because one area overrides another, or left with just the existing one, or a mysterious no-operation, or worse, a duplicated operation and feedback loop resulting in a stuck or spamming key.

Asserting your instructions through this entire stack is a challenge. But taking ownership has long term rewards because as you can see, all computer manufacturers, especially Mac, are taking away your keys one by one, and replacing them with "Apple-buy it now!" buttons, and fart buttons on laugh tracks when you press escape, which self-remaps to "Apple-buy-it-now".

0

I had this issue too.

I fixed it by going into the Keyboard Shortcuts menu (Tools -> Extensions -> Keyboard Shortcuts (scroll to bottom)), selecting each Shortcut box, and trying to press (on Mac) Command + Shift + Alt + 5 + 6 + 7 + H + F5 ..... You get the idea. This should work on any other OS too.

Try using a bunch of modifier keys and smacking the keyboard with your hand (or head!) until it says "Not set".

0

The most annoying shortcut for me is Ctrl+Alt+O, which is IntelliJ's optimize imports shortcut. Chrome hijacks that to open its stk window.

To disable that, open the configuration menu and uncheck Hot Keys: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy