I have an Asus n56v and I've got troubles installing Ubuntu 12.04 x64.

I already have installed Windows 7 x64!

The hard drive is: Hitachi HTS547575A9E384

My problem:
The installation program doesn't recognize the already existing partitions and is offering only options where there are partitions.

Can someone help me out?

Is this an ACPI/IDE conflict, missing driver or conflict with Windows 7?

(I'm not an expert on Linux, only working sometimes with it.)

I now tried out some options concerning EFI with a GTP-table. Everything worked but I wasn't able to fix a dual boot (Windows boot loader) nor with GRUB2.

The laptop is still having a BIOS, but is able to boot DVDs/CDs in EFI-mode.

Now I try to avoid EFI and GTP using the old windows MBR style. I reinstalled Windows, so far no problem.

When I want to try to install Ubuntu, it doesn't detect the already existing partition table. It is just showing me an empty space for the whole disk.

Other threads like Ubuntu 12.04 does not see windows already install on my computer (dual installation) don't help me out.

os-prober shows me a correct result.

I don't know how to deal with gdisk as shown in Installer doesn't detect existing partition table/windows 7 partition.

I have 750GB for the whole disk. I'm using: 90GB for Windows reserved partition + system partition, 500GB for data and the rest should be for SWAP and linux-system.

How can I make Ubuntu detect the partition table?

  • 2
    which options do you see? – Alen Jul 11 '12 at 21:45
  • you should see option for dual boot with your windows 7. If not then log in to windows, install magic partition. Make two partitions, one for your system and one for swapping. Partition for your system should be ext4 format, and swap partition just leave it as it is. Now boot your Ubuntu CD and choose option "Something else" – Alen Jul 13 '12 at 14:32
  • you should install windows first so after you install linux, GRUB will show up every time you boot. – Alen Jul 14 '12 at 15:04
  • ubuntu even doesn't detect that windows is installed ... :/ – user76439 Jul 15 '12 at 23:53

Before installing windows: it may not be necessary,: a) start live-cd / stick and use gparted, create a GPT-partition table as followed: leave some empty space for windows (~120GB), then create a possible swap and root partition for ubuntu. (maybe it will work without: in my case it didn't)

b) installing windows, using the free space: windows will automatically set the partitions (3 partitions: one UEFI, one windows boot, one windows data)

c) It did not work installing from the CD (bios was able to boot win7 in uefi, but was not able to boot ubuntu in uefi), however from usb-stick went fine.

ubuntu needed an 1MB partition with the "flag": bios_grub (when made with gparted), also possible if you set the partition type (using the installer): boot-partition from the installer partitioning program

d) I created my partition table: sda5: swap (8GB), sda6 (100GB), sda7 (1MB); I selected sda1 for the location of the bootloader (the selection below the partition table) (the efi-partition - sda1 in my case - can keep a lot of boot-loaders

The installer automatically set up an uefi bootloader (in my case) named "linuxmint"

e) open terminal: mount all partitions as before and try again the efibootmgr command (two bullets above) and continue: edit /etc/grub.d/40_custom adding and insert the following:

menuentry "Windows x86_64 UEFI-GPT" { search --fs-uuid --no-floppy --set=root ###-#### chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi }

-#### is the UUID from sda1 (to find out use: 'ls -la /dev/disk/by-uuid/')

advice: use grub-customizer for easier handling

f) use: "update-grub" and restart: the correct bootloader (if you're looking into bios) is named: linuxmint (P0...), not GRUB2 (if avaible too)


  • I consider it fixed ... my answer is a report, how I fixed my own problem ... – user76439 Jul 23 '12 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.