72

After booting to the GUI in 12.04, I attempt to move to the virtual terminal (or shell, or tty) via Ctrl-Alt-F1 (F1 through F6), and the screen remains blank. I have tried all 6 tty instances and the results are the same. Ctrl-alt-F7 brings me back to the GUI without a problem. Any thoughts?

  • This occurs often together with being unable to see Grub of the boot splash. Can you see those? – hexafraction Jul 11 '12 at 20:11
64

This is usually caused because the graphical text-mode resolution set at boot up is not compatible with your video card. The solution is to switch to true text-mode by configuring Grub appropriately:

  1. Open the terminal with Ctrl+Alt+T
  2. Paste the below, and enter your password when asked:

    sudo sed -i -e 's/#GRUB_TERMINAL/GRUB_TERMINAL/g' /etc/default/grub
    
  3. Then type sudo update-grub

  4. Reboot and the virtual terminals should now work.
  • 1
    Unfortunately, this didn't help with my graphic-driver issues (I need the X server down to install proper drivers, but the lack of drivers prevents me from getting a working command-line with ctrl-alt-F1). – Jonathan Y. Feb 1 '15 at 20:34
  • 8
    CAREFUL, this thing has completely messed up my grub, I don't see a boot menu anymore. (Ubuntu 15.04) – Arty Oct 25 '15 at 3:21
  • 1
    @MinaMichael No. It changes #GRUB_TERMINAL to GRUB_TERMINAL. The slash ends the regular expression, and the g is the global-modifier that sais: replace ALL matches. – Philipp Zedler Jan 12 '16 at 11:23
  • 1
    Doesn't work on 14.0.4 for me – Zach Rattner May 17 '16 at 1:57
  • 2
    Grub file states # Uncomment to disable graphical terminal (grub-pc only) #GRUB_TERMINAL=console Why would disabling graphical terminal fix this issue? For Ubuntu 16.04 – Sun Bear Mar 10 '17 at 17:56
14

What fixed this for me was adding nomodeset to the GRUB_CMDLINE_LINUX_DEFAULT line in the /etc/default/grub file. Here's how:

  1. Type in terminal: gksu gedit /etc/default/grub

  2. Search for this line: GRUB_CMDLINE_LINUX_DEFAULT

    So for example if you have:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"
    

    change it to:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 nomodeset"
    
  3. After you finish, update grub (sudo update-grub) and reboot (sudo reboot) for the changes to take effect.

Optional: You could add nomodeset vga=xxx (not just nomodeset), the xxx is a VESA screen code that best matches your screen resolution. Take a look at this.

  • 2
    Worked for me. Be sure to read the last paragraph above, about running sudo update-grub to apply the changes. – Andy Thomas Mar 18 '16 at 20:44
  • Worked for me on 14.0.4 – Zach Rattner May 17 '16 at 1:58
  • 1
    When I do this with 14.04 and some Hardware enabling stack whatever this works technically, but graphical desktop is not booted into nor does startx work. But the terminal is back. – hakre Sep 16 '16 at 16:10
  • 1
    For me On Ubuntu 16.04 this caused my HDMI-VGA monitor to completely stop working. – Padraic Cunningham Dec 22 '16 at 17:21
  • @PadraicCunningham you can undo it from tty. I hope it wasn't too much trouble – Mina Michael Dec 22 '16 at 20:49
6

This is for newer version of Ubuntu:

  1. Edit the GRUB configuration file:

    sudo nano /etc/default/grub
    
  2. Locate the line

    #GRUB_GFXMODE=640x480
    

    change it to

    GRUB_GFXMODE=auto
    

    and save the file.

  3. Then update grub

    sudo update-grub
    
  • On Ubuntu 14.04.5 I installed a program that caused a 4.x kernel to be installed. Previously I had a 3.x kernel. This answer is what fixed this issue of blank ttys for me on an Asus Zenbook UX303LN. – frederickjh Apr 17 '18 at 12:30
1

Please take a look at my question at https://answers.launchpad.net/ubuntu/+question/643882, with regards to virtual terminal not functioning on Ubuntu 16.04 on Lenovo Thinkpad T400.

The solution i presented is geared towards user with Hybrid Graphics Card, in particular, AMD/ATI graphics card and Intel integrated graphics card. For me, disabling the intel graphics card and enabling the opensource ATI/AMD radeon module helps in my case.

If you are using a old Radeon graphics card like mine (Radeon HD 3450/3470), now you can switch between virtual terminal and graphical desktop with ease to troubleshoot potential issues.

If adding blacklist intel_graphics_card in /etc/modprobe.d/blacklist.conf and running

sudo depmod -a 

still doesn't work due to linux kernel or other dependencies, you are advised to add modprobe.blacklist=<module_name> to /etc/default/grub like the following example:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash crashkernel=384M-:128M radeon.dpm=1  modprobe.blacklist=i915"
0

You need to shut down the graphics driver after you Ctrl+Alt+F1 before you try to install the Nvidia driver

As in sudo /etc/init.d/lightdm stop

  • 3
    "before you try to install the Nvidia driver" - I'm not sure what you mean by that. The question doesn't mention anything about Nvidia drivers. – wjandrea Oct 2 '17 at 18:20
0

Here is what worked for me on Ubuntu 18.04 with 2560x1440 screen:

  • open grub configuration file in editor: sudo gedit /etc/default/grub

  • uncomment GFXMODE and set your exact resolution -> change#GRUB_GFXMODE toGRUB_GFXMODE=2560x1440

  • add line GRUB_GFXPAYLOAD_LINUX=keep

  • Add remove splash and add nosplash noplymouth nomodeset to your GRUB_CMDLINE_LINUX_DEFAULT. After cahnges mine looks like GRUB_CMDLINE_LINUX_DEFAULT="quiet nosplash noplymouth intel_idle.max_cstate=1 nomodeset"

  • save the file

  • update grub sudo update-grub

  • reboot

  • use Ctlr+Alt+F2 to switch immediately after boot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.