I am getting this message every time I do something like starting or stopping a service.

perl: warning: Setting locale failed.   
perl: warning: Please check that your locale settings:   
        LANGUAGE = "en_US:en",   
        LC_ALL = (unset),   
        LC_MESSAGES = "en_US.UTF-8",   
        LANG = "en_US.UTF-8"   
    are supported and installed on your system.   
perl: warning: Falling back to the standard locale ("C").   
locale: Cannot set LC_CTYPE to default locale: No such file or directory   
locale: Cannot set LC_MESSAGES to default locale: No such file or directory   
locale: Cannot set LC_ALL to default locale: No such file or directory   
(Reading database ... 21173 files and directories currently installed.)  
Removing bind9 ...  
 * Stopping domain name service... bind9                                        [ OK ]
Processing triggers for man-db ...   
locale: Cannot set LC_CTYPE to default locale: No such file or directory   
locale: Cannot set LC_MESSAGES to default locale: No such file or directory   
locale: Cannot set LC_ALL to default locale: No such file or directory   

How do I fix this error ?


20 Answers 20


First run locale to list what locales currently defined for the current user account:

$ locale

Then generate the missing locale and reconfigure locales to take notice:

$ sudo locale-gen "en_US.UTF-8"
Generating locales...
  en_US.UTF-8... done
Generation complete.

$ sudo dpkg-reconfigure locales
Generating locales...
  en_US.UTF-8... up-to-date
Generation complete.

Now you will not see any errors anymore!

  • 270
    did not work for me
    – Umair Ayub
    Commented Apr 24, 2014 at 7:43
  • 4
    This has worked for me on a number of systems. Is there a way to avoid this issue on newly installed systems? Commented Jan 12, 2015 at 17:34
  • 13
    @UmairAyub may be you have more than one unknow locale, try this: for y in $(locale | cut -d '=' -f 2| sort |uniq );do locale-gen $y; done It will generate a locale for each definition you have Commented Jun 27, 2015 at 18:33
  • 5
    Logout and Login may help Commented Nov 16, 2015 at 18:09
  • 6
    @Umair There is a high risk of human error in this problem. Your system is configured to en_GB by default, but you set it up to en_US. You have to manually comment en_GB and uncomment en_US in /etc/locale.gen. See my answer askubuntu.com/a/790373/25388 in the hardware Raspberry Pi 3b and the system Raspbian Jessie. Commented Jun 22, 2016 at 20:27

Nothing suggested above worked in my case (Ubuntu Server 12.04LTS). What finally helped was putting to the file /etc/environment:


For some reason it was missing. The outputs for locale and other commands appeared like the variables were properly defined. In other words don't take for granted all the basic stuff is declared where it should be declared.

  • 132
    Yes, none other worked except this one, perhaps due to updated version. But I rather prefer to put this in /etc/default/locale.
    – Naveed
    Commented Feb 22, 2013 at 20:18
  • 30
    Updated /etc/default/locale and no more warnings. Thanks
    – ohho
    Commented Feb 26, 2013 at 7:00
  • 9
    Yep, the others didn't work for me. This one did. Here is the one-liner I used for unattended updating of this. sudo sh -c "echo 'LC_ALL=en_US.UTF-8\nLANG=en_US.UTF-8' >> /etc/environment"
    – dman
    Commented Mar 22, 2014 at 6:01
  • 16
    @user163207 your solution is incorrect because it appends (instead of overwriting), it's not the recommended file, and echo needs to be run with the interpretation of backslash escapes enabled. This is the same as yours but with the aforementioned fixed: sh -c "echo -e 'LANG=en_US.UTF-8\nLC_ALL=en_US.UTF-8' > /etc/default/locale"
    – glarrain
    Commented Apr 9, 2014 at 21:22
  • 15
    DON'T FORGET TO LOGPUT AND RE-LOGIN! Commented Nov 16, 2015 at 18:05

They should disappear after issuing:

sudo locale-gen en_US en_US.UTF-8
sudo dpkg-reconfigure locales 

dpkg-reconfigure reconfigures packages after they have already been installed. Pass it the names of a package or packages to reconfigure. It will ask configuration questions, much like when the package was first installed.

  • 10
    I am glad my troubles a year ago helped you get this fixed ;)
    – Rinzwind
    Commented Jul 11, 2012 at 14:34
  • 1
    Shouldn't this locale be generated by default? I mean en, en_AU, en_CA, en_GB are present by default but not en_US? Commented Aug 15, 2012 at 16:05
  • @Rinzwind Thanks a lot for your effort! I do apologize; I should have worded my question better. What I meant to ask is: Why is it necessary to reconfigure the locales package after generating new locales? Seems to me like the locales work even without dpkg-reconfigure.
    – Victor
    Commented Nov 18, 2012 at 11:49
  • Using Ubuntu 14.04, in a Docker container, so nothing was being set. Django's makemessage needs this. This worked perfectly! thanks.
    – Justin
    Commented Aug 11, 2014 at 18:05
  • 2
    I realize that raspbian is out of scope here, but I thought I'd mention that I had to logout and login before LC_ALL was properly set. Commented Dec 29, 2017 at 18:27

Just add the following to your .bashrc file (assuming you're using bash)

export LC_ALL="en_US.UTF-8"
  • 3
    This sweet fix worked for me on my Amazon-EC2 image (Was running their default RHEL AMI) Thanks so much! :)
    – gideon
    Commented Dec 1, 2012 at 15:07
  • This one worked for me with my digitalocean's Ubuntu 12.04 image.
    – Inan
    Commented Sep 25, 2013 at 11:49
  • 3
    this fixed my problem. I have to ask a question: how come the LC_ALL was not set by the locale-gen command as other answers said above this one ?
    – alexserver
    Commented Sep 21, 2015 at 18:35
  • 1
    Weird, all solution above didn't work for me but this one did! After exporting LC_ALL I could finally use sudo dpkg-reconfigure locales.
    – sobi3ch
    Commented Nov 18, 2015 at 11:56
  • finally after trying a lot of tricks , this is the working one for me on kubuntu 14.04.3 lts . thanks!
    – Yunus
    Commented Jan 8, 2016 at 20:44

This is a common problem if you are connecting remotely, so the solution is to not forward your locale. Edit /etc/ssh/ssh_config and comment out SendEnv LANG LC_* line.

  • 6
    I was trying other answers, but forgot I was connecting remotely until I saw your answer. Different locales on the ssh server and client was causing the problem.
    – Hieu
    Commented Feb 27, 2015 at 6:32
  • 2
    On OSX (connecting to ubuntu) it's at /etc/ssh_config Commented Jun 3, 2015 at 10:01
  • One-liner to do this: sed -e '/SendEnv/ s/^#*/#/' -i /etc/ssh/ssh_config (useful for server provisioning)
    – Albin
    Commented Jun 16, 2015 at 16:57
  • I couldn't set LC_ALL on the locale machine but it fixed my problem with the remote server, thanks. Commented Aug 26, 2016 at 20:33
  • 3
    Probably worth noting that you have to edit the file on the local machine not the remote.
    – Clashsoft
    Commented Jul 9, 2018 at 18:08

There is a command for that:

sudo update-locale LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8

It updates /etc/default/locale with provided values.

To apply the changes, you can

source /etc/default/locale
  • 5
    This is legit! Don't forget to sign out / reload your shell, or else you won't see the changes. Don't forget to check out the approved answer for generating and reconfiguring locales. Commented Feb 8, 2016 at 10:28
  • 2
    Running locale still doesn't show any utf values.
    – Cerin
    Commented Apr 18, 2017 at 23:00
  • 2
    This won't change LANG for the root shell on Ubuntu 16.04, as it is overruled in /root/.profile.
    – Willem
    Commented Dec 31, 2017 at 16:44
  • 1
    *** update-locale: Error: invalid locale settings: LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8
    – alper
    Commented Mar 2, 2022 at 8:51
  • 1
    @alper You first need to locale-gen "en_US.UTF-8" and then and only then check it on sudo dpkg-reconfigure locales Commented Jun 23, 2023 at 0:09

What worked for me on 12.10 was this:

apt-get install language-pack-en-base  

This was after dpkg-reconfigure locales produced no results.

  • 2
    This is the best answer. It's not that my locales were setup incorrectly, but they didn't actually exist. I think this is similar to the OP's problem as well ("No such file or directory" is pretty clear if your locale is set right!). Commented Oct 27, 2013 at 21:49
  • 1
    I was getting the OPs issue ever time i was using apt-get on Ubuntu 12.04 This solved it perfectly without having to edit any files.
    – Deepend
    Commented Jun 10, 2014 at 10:13
  • "language-pack-en-base is already the newest version."
    – karlingen
    Commented Aug 10, 2015 at 7:51
  • Logout and Login may help Commented Nov 16, 2015 at 18:09
  • Worked for me in an ubuntu chroot under debian. Thanks :)
    – Wyatt Ward
    Commented Feb 18, 2016 at 13:25

Don't forget exit your SSH session (or your X11) by exiting and logging back in again. All of these suggestions didn't work for me unless I logged back in....

  • 2
    This comment should get more upvotes or atleast the fact needs to be highlighted in every answer.
    – ni8mr
    Commented Dec 9, 2016 at 14:24

I was stuck in a weird state where my local machine is set to es and so the remote machine (via vagrant) had been provisioned in an un-handled state. Therefore, I had to use the manual export= only to facilitate a successful dpkg-reconfigure. Then the system is fine.

export LC_ALL="en_US.UTF-8"
sudo dpkg-reconfigure locales
  • 1
    Best! Due to dpkg-recofigure displays mojibake. Commented Jun 28, 2017 at 13:47
  • 2
    This is the only one works.
    – Eric
    Commented Jun 9, 2023 at 16:20
  • I tried literally everything else, and this is the only solution that finally resolved it for me.
    – RolandiXor
    Commented May 30 at 2:51

For Ubuntu 12.10 none of the above worked except for ratzs' solution. I recommend adding this to your /etc/bash.bashrc file:

export LC_ALL="en_ZA.UTF-8"
export LC_CTYPE="en_ZA.UTF-8"
  • Of all the solutions above. This is the only that worked for me.
    – JohnnyQ
    Commented May 11, 2016 at 6:56

I wrote a bash script to fix above issue.The above answers are useful but setting the locale variables by simply exporting the values in shell variable will work only for a session. I permanently solved this issue by exporting the locale variables in .bash_profile file. You can also use /etc/profile file instead of .bash_profile.

echo "export LANGUAGE=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8">>~/.bash_profile

Don't forget to source the .bash_profile and follow the script in easy setup.


You can try:

export LANGUAGE=ru_RU.UTF-8
export LC_CTYPE=ru_RU.UTF-8
export LC_NUMERIC=ru_RU.UTF-8
export LC_TIME=ru_RU.UTF-8
export LC_COLLATE=ru_RU.UTF-8
export LC_MONETARY=ru_RU.UTF-8
export LC_MESSAGES=ru_RU.UTF-8
export LC_PAPER=ru_RU.UTF-8
export LC_NAME=ru_RU.UTF-8
export LC_ADDRESS=ru_RU.UTF-8
export LC_ALL=ru_RU.UTF-8

where ru_RU is your country code.


Current accepted answer is not sufficient in the troubleshoot strategy because you can have an human error. You setup your system to en_US but you have en_GB enabled in/etc/locale.gen like I had in the thread here for Raspberry Pi 3b. You should have all your used locales enabled in /etc/locale.gen.

I had en_GB.UTF-8 UTF-8 only enabled in /etc/locale.gen. I should have there only enabled en_US.UTF-8 UTF-8 because of other commands run for it. So I commented GB and uncommented US, and everything work now

masi@raspberrypi:~ $ sudo vim /etc/locale.gen

masi@raspberrypi:~ $ sudo locale-gen 
Generating locales (this might take a while)...
  en_US.UTF-8... done
Generation complete.

masi@raspberrypi:~ $ sudo a2enmod rewrite && a2enmod headers && a2enmod ssl
Module rewrite already enabled
Module headers already enabled
Considering dependency setenvif for ssl:
Module setenvif already enabled
Considering dependency mime for ssl:
Module mime already enabled
Considering dependency socache_shmcb for ssl:
Module socache_shmcb already enabled
Module ssl already enabled

Now, I do not get those locale mistakes with any commands.

System: Raspbian Jessie
Hardware: Raspberry Pi 3b


As said here in the Debian Wiki, you can edit /etc/locale.gen and add all locales (or uncomment them, I had a list of all locales but all except the one I used as comments) you wish to have support for on your system. Then, execute

sudo dpkg-reconfigure locales

to update the locales on your system. Now, all of the locales you added/uncommented in /etc/locale.gen are available on your system without any warnings.


If you use KDE environment, check the setlocale.sh file in ~/.kde/env/:

$ cat ~/.kde/env/setlocale.sh 
export LANG=en_US.UTF-8
export LANGUAGE=en_US:ru:en
  • 1
    this saved my ass.... thank you! Unbelievable how many places this locale crap is being set in... and how in the world does KDE manage to screw things up by mixing my two different locales (is_IS for location, money, etc and en_EN for language into a non-existent is_EN locale)! Grmpfh.
    – StFS
    Commented May 27, 2016 at 11:05
  • I have been struggling with this for weeks! No other answer helped me. I couldn't even assume that KDE messes with the locale in its own way. I didn't know about the setlocale.sh file and not a single tutorial mentions it. Commented May 28, 2021 at 6:00

This worked for me when I had the same problem (based on the solution provided by dman):

sudo sh -c "echo -e 'LC_ALL=en_US.UTF-8\nLANG=en_US.UTF-8' >> /etc/environment"
  • I wasn't quite sure how to add the url to the comment. @EliahKagan Commented Aug 27, 2014 at 6:28
  • 1
    No problem--the date/timestamp next to a comment is what links to it directly. ...So, I've noticed glarrain's comment (calling for > instead of >>) seems like a reply to dman's. I don't actually know which way is right or best, but if you have any insight into this you could expand this answer with more information. (You don't have to though.) Commented Aug 27, 2014 at 6:32
  1. You may need to run sudo dpkg-reconfigure also for the application you have installed while "locale" settings have been invalid / not matching.

    While system locale was incorrectly setup I installed vim. Later when system locale was fixed I saw a situation that vim was showing utf-8 characters incorrectly as strange symbols while nano and less were showing them correctly. Running

    sudo dpkg-reconfigure vim

    appeared to fix the issue after the system settings were fixed.

  2. I also noticed the same thing as already mentioned: You may need to disconnect/reconnect SSH to make changes visible.


Adding the following text to ~/.profile works for me:

export LANGUAGE=en_US.UTF-8
export LC_ALL=en_US.UTF-8

I am using Ubuntu 16.04 LTS 64-bit server on Linode.


Source of the problem

I experienced this, logging in from one machine to another via ssh. The remote machine didn’t have the locale files, that I had on my local machine. You can either disable the forwarding of the locale from your local machine to the remote machine (in the file /etc/ssh/sshd_config remove the line AcceptEnv LANG LC_CTYPE …) or install the locale (changing it is not necessary in this case).


On Fedora, RHEL, Redhat, CentOS I used

sudo dnf install langpacks-de

for the german (de) language packs. Logged out and in and it worked.

Search for other langpacks with

dnf search langpacks-


To list available locales I used

localectl list-locales

And to set a new one

sudo localectl set-locale de_DE.utf8
  • dnf are not Ubuntu or flavor commands, how is this helpful on this site? askubuntu.com/help/on-topic
    – guiverc
    Commented Sep 29, 2020 at 7:59
  • This problem is not specifically an Ubuntu problem. I gave general instructions in the first paragraph. And then an example of how to do it on a specific distribution, where I had the problem. It is basic knowledge how to translate that to another distributions package management system.
    – erik
    Commented Sep 30, 2020 at 8:34
  • If you wanted to post this answer, I feel the question should have been re-asked on SE Unix & Linux and the answer used there, thus being on-topic.
    – guiverc
    Commented Sep 30, 2020 at 8:38
  • My answer is absolutely on topic. None of the answers tells what the real problem is, the source of the problem. Package installation is trivial, or should be asked in a different question. It is quite similar on all distributions, also on Debian or Ubuntu. And the rest of the solution works fine on every modern linux distribution. And I mentioned explicitly my distributions. Instead of complaining you could add the Debian/Ubuntu commands. That would be helpful.
    – erik
    Commented Sep 30, 2020 at 16:16

remove locales using localepurge you don't need and reboot

apt install localepurge

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .