After a recent update, ttf-mscorefonts-installer prompted me to accept its license agreement.

 ┌─────────────────┤ Configuring ttf-mscorefonts-installer ├─────────────────┐
 │                                                                           │ 
 │ TrueType core fonts for the Web EULA                                        
 │ IMPORTANT-READ CAREFULLY: This Microsoft End-User License Agreement         
 │ ("EULA") is a legal agreement between you (either an individual or a        
 │ single entity) and Microsoft Corporation for the Microsoft software         
 │ accompanying this EULA, which includes computer software and may include    
 │ associated media, printed materials, and "on-line" or electronic            
 │ documentation ("SOFTWARE PRODUCT" or "SOFTWARE"). By exercising your        
 │ rights to make and use copies of the SOFTWARE PRODUCT, you agree to be      
 │ bound by the terms of this EULA. If you do not agree to the terms of        
 │ this EULA, you may not use the SOFTWARE PRODUCT.                            
 │                                  <Ok>                                       
 │                                                                           │ 

enter image description here

For some reason my terminal will not allow me to accept, or for some reason I am pressing the wrong hotkey... I've tried every letter on the keyboard and Enter among others... I'm sure there is a very simple and obvious solution to this.

I've also just tried to remove the package completely however the terminal states that due to the package not being correctly installed, I should reinstall the package before removing it. Very frustrating! Essentially, because I cannot successfully install this package, I can't really ever upgrade my system because I always have to end up terminating the terminal with the license agreement (thus the upgrade fails).


5 Answers 5


It's  ⇆ TAB , then return ↵.


In general, to navigate ncurses-style menus:

  • Use the Tab key to move from one element (e.g., button, text box) to the next. Use Shift+Tab to move in reverse.
  • Use Spacebar to "click" the selected button.
  • Use Enter to click the default button (or currently selected button, if there is no default).
  • You can move up and down in a textbox with the arrow keys, and with Page Up and Page Down. If that doesn't work, press Tab until the text box you want to navigate in is selected.

If you've accidentally said you don't agree to the EULA, and you want a chance to review it again and agree, you can reinstall ttf-mscorefonts-installer, purging its global configuration files:

sudo apt-get --purge --reinstall install ttf-mscorefonts-installer
  • 47
    Personally, I think curses is wrong, you should be able to just press return. :P Feb 10, 2011 at 15:29
  • 8
    Wow, I would have never figured that out. Does this only happen with Microsoft installers?
    – B Seven
    Aug 24, 2013 at 2:56
  • 1
    @BSeven: I guess Microsoft did not do the packaging on this one and the maintainer of the package implemented that dialog. But most of the time you don't have to accept EULAs when installing packages, so ...
    – Joey
    Jun 24, 2014 at 5:09
  • 7
    I thought I'm the only person facing this, andI'm the only stupid to have not figured this out.. but it seems 121 users have upvoted the question and 161 liked as of date, I'm not the only one. you saved many of us. thnx Apr 24, 2015 at 9:30
  • 9
    "Well I'm probably stupid but let's try Google... Oh it auto-completed! So there are at least a few people searching..." (Sees 300 upvotes) "Ok I'm normal!" Nov 1, 2018 at 16:02

Normal install, deploying or in scripts

Use debconf to preset the selection. This will not prompt to accept the license:

echo ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true | sudo debconf-set-selections
sudo apt-get install ttf-mscorefonts-installer

With Kickstart

Add this to your Kickstart.cfg file:

preseed --owner ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula boolean true
  • 6
    When using --quiet, will it automatically accept the licence? Nov 4, 2013 at 17:53
  • I needed two debconf entries: echo ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true | sudo debconf-set-selections and echo ttf-mscorefonts-installer msttcorefonts/present-mscorefonts-eula note | sudo debconf-set-selections
    – Janning
    Oct 31, 2014 at 9:06
  • 1
    @king_julien: no, --quiet will not accept the license, so that should not be an option without echo ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true | sudo debconf-set-selections!
    – rubo77
    Oct 27, 2015 at 10:42
  • I removed the command without sudo and non-working --quiet option. Feel free to revert the edit if this is too much change, but I think the answer is much clearer like this now
    – rubo77
    Oct 27, 2015 at 10:48
  • 1
    how did you come up with the syntax for that? that's the interesting part. I want to apply this to Java jdk, steamcmd, ect
    – tatsu
    Mar 2, 2019 at 11:13

You can also accept the license with a single command like this:

echo ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true | debconf-set-selections

This will avoid creating the conf file.

If your using puppet, here is a recipe for installing the package:

class unifocus-context::msfonts {
  exec { "accept-msttcorefonts-license":
    command => "/bin/sh -c \"echo ttf-mscorefonts-installer msttcorefonts/accepted-     mscorefonts-eula select true | debconf-set-selections\""

  package { "msttcorefonts":
    ensure  => installed,
    require => Exec['accept-msttcorefonts-license']

Some people may find this question when searching for help installing ubuntu-restricted-extras (or when their questions accepting a EULA for ubuntu-restricted-extras are closed as a duplicate of this question).

ubuntu-restricted-extras is a metapackage that exists solely to install other packages.

One of those packages is ttf-mscorefonts-installer. That's the one you must agree to a EULA to finish installing. It fetches Microsoft fonts and installs them on your system.

  • To agree to the EULA, use the Tab key to switch from "button" to "button" in the non-graphical "window", and either the Spacebar ("clicks" the selected "button") or the Enter key ("clicks" the "default" button). You can move up and down in the EULA with the arrow keys and with Page Up and Page Down.

  • If you've accidentally said you don't agree to the EULA, and you want a chance to review it again and agree, you can reinstall ttf-mscorefonts-installer, purging its global configuration files:

    sudo apt-get --purge --reinstall install ttf-mscorefonts-installer
  • If you decide you don't want those fonts at all (or are unwilling to accept the EULA for them), but you do want the other packages provided by ubuntu-restricted-extras, then remove ttf-mscorefonts-installer and make sure you have the other packages and that they're set to manually installed (so they don't go away in an autoremove after ubuntu-restricted-extras is removed with ttf-mscorefonts-installer):

    sudo apt-get remove ttf-mscorefonts-installer
    sudo apt-get update
    sudo apt-get install ubuntu-restricted-addons gstreamer0.10-plugins-bad-multiverse libavcodec-extra-53 unrar
  • 4
    Is it possible to install the ubuntu-restricted-extras and automatically accept the licence in one command? Nov 4, 2013 at 17:59

Try hitting (The right arrow key). Then use the arrow keys to navigate and enter (That's return) for selecting an option.

  • Well the enter(return) key didn't work. Also the right arrow cannot be used for navigation either.
    – Kolappan N
    Apr 24, 2015 at 8:19
  • Brilliantly simple answer thats just saved me a lot of pain
    – MRL
    Dec 19, 2021 at 13:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.