I am using Toshiba Satellite L300. Installed Ubuntu 12.04 as fresh install. Just after the installation, I tried hibernating the system using command pm-hibernate , which went well. The suspend too worked automatically. Two days ago, I found that the suspend isn't working. The suspend button takes to the resume screen. The same with hibernate. I suspected a kernel update has caused this. But booting into older kernels isn't helping. Hate Toshiba for making laptops incompatible with Ubuntu. But can anyone suggest any fix for this problem for now. Thanks in advance.

  • I think, this is a bug. The same goes for Casper's Nirvana Series. Even if you are out of battery, system goes to lock screen after suspend-like behaviors again and again. – Hilmi Erdem KEREN Jul 10 '12 at 13:03
  1. Open your Terminal.
  2. Run sudo modprobe toshiba_acpi.

Did that fix the problem? If so, you can:

  1. Open your Terminal, if it's not already open from before.
  2. Run sudo nano /etc/modules.
  3. Add toshiba_acpi to the end of the file.
  4. Save and exit. This loads the toshiba_acpi module on boot.

You can, alternatively, add the following to the end of the file /etc/rc.local (creating the file if it does not already exist):

modprobe toshiba_acpi
exit 0

Like erdemkeren says this is a bug, please report it on Launchpad. for more a howto: https://help.ubuntu.com/community/ReportingBugs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.