I have a freshly installed Ubuntu 12.04

I need to install telugu language (I have been using it successfully in my earlier ubuntu 11.04).

But the Language support is saying:

Software database is brocken- you can not add or delete any package...

I looked up in the net, updated and upgraded the system as suggested, to no avail.

It looked like the problem is with the Default locale.

I tried this too:

sudo dpkg-reconfigure locales [sudo] password for narayana: Generating locales... en_AG.UTF-8... up-to-date en_AU.UTF-8... up-to-date en_BW.UTF-8... up-to-date en_CA.UTF-8... up-to-date en_DK.UTF-8... up-to-date en_GB.UTF-8... up-to-date en_HK.UTF-8... up-to-date en_IE.UTF-8... up-to-date en_IN.UTF-8... up-to-date en_NG.UTF-8... up-to-date en_NZ.UTF-8... up-to-date en_PH.UTF-8... up-to-date en_SG.UTF-8... up-to-date en_US.UTF-8... up-to-date en_ZA.UTF-8... up-to-date en_ZM.UTF-8... up-to-date en_ZW.UTF-8... up-to-date Generation complete. narayana@Subhan:~$ sudo apt-get --reinstall install language-pack-te Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: language-pack-te : Depends: language-pack-te-base (>= 1:12.04+20120508) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Dint' gain much- did I? Please help.

(By the way the ubuntu software manager is able to install other software like gimp etc)

  • Try sudo apt-get install -f – Mitch Jul 10 '12 at 6:39
  • Tried it: no use. 'narayana@Subhan:~$ sudo apt-get check -f [sudo] password for narayana: Reading package lists... Done Building dependency tree Reading state information... Done' – narayana Jul 10 '12 at 8:59
  • It looks like you have tried check -f. Did you? – Mitch Jul 10 '12 at 9:00
  • The formatting of text from the Terminal in this question is very badly broken and cannot be easily fixed by someone else editing the question. I recommend producing the Terminal text again, editing your answer pasting it in, selecting the text immediately after pasting it into your answer, and applying proper formatting to it with the <$> tool in the Ask Ubuntu editing toolbar. – Eliah Kagan Jul 11 '12 at 13:43

The answer to the above question seems to be a bug in Ubuntu12.4 distro- Please see https://bugs.launchpad.net/ubuntu/+source/language-pack-te/+bug/1023261

The solution seems to be that one uses an older version of language-pack-te.

I am yet to use the older version as suggested.


If the package manager says you have unmet dependencies, you can run the following command from a terminal sudo apt-get check -f <- That will check for unmet dependencies and try to fix them.

  • I tried that: narayana@Subhan:~$ sudo apt-get check -f [sudo] password for narayana: Reading package lists... Done Building dependency tree Reading state information... Done narayana@Subhan:~$ – narayana Jul 10 '12 at 4:17
  • Can you manually install language-pack-te-base by running sudo apt-get install language-pack-te-base? – Corey Whitaker Jul 10 '12 at 4:22
  • I tried that as well, to no avail. It says I am holding broken packages..but the packages are not installed yet. I tried installing language-pack-te-base through synaptic as well. No use. – narayana Jul 10 '12 at 4:33
  • Try removing all references to the broken package(s) from /var/lib/dpkg/status to remove them, just delete the entire block of text. – Corey Whitaker Jul 10 '12 at 4:34
  • all packages listed in /var/lib/dpkg/status showed status: install ok installed. No package installed seems "broken" as such. – narayana Jul 10 '12 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.