My problem seems to be relatively simple: I would like to be able to watch simple videos on Ubuntu 11.10 (Oneiric), using an ATI Mobility Radeon HD 3450, 256 MB graphics card, presently relying on the fglrx driver (but would readily change to anything that can give me that and a cool fan) installed from the repositories, but video playback is plain UGLY.

What I am experiencing: On various players, incl. the default Totem, VLC, as well as the MPlayer-based SMPlayer and Gnome Player video playback is either plain ugly, (motions are sloppy, occasionally, at lower res. xvid avi videos even leaving a very slight trail, and at faster motions horizontally "breaking" in two in the upper segment of the screen) or just similarly breaking in high resolution H264-encoded 720p, 1080p mkv videos and motion hardly feels continuous, feels like...dragged.

Moving any window around over the desktop is pretty blurry, too, (text in a gedit window for instance becomes unreadable when moved around).

What I do not need: I will not play any 3D games, need no super fancy desktop effects, or anything, only my videos.

My hardware is:

Dell Studio 1535 Intel® Core™2 Duo CPU T9300 @ 2.50GHz × 2 4096MB RAM ATI Mobility Radeon HD3450, 256MB dedicated memory Resolution: 1440 x 900

My present software situation:

I have installed fglrx successfully, the output of fglrxinfo seems to indicate what it is supposed to:

display: :0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon HD 3400 Series
OpenGL version string: 3.3.11005 Compatibility Profile Context

However, under "Graphics", System Settings >> System Info displays this: "Driver VESA:M82; Experience Standard".

What I have tried:

  • Ubuntu 12.04 is out of the question: with my hardware it proved to be way too buggy. (My typical experience with LTS distributions.)
  • Ubuntu 11.10. clean install, installing Catalyst 12.04. (The version suggested by the ATI website for my graphics card.) The output of fglrxinfo proved the driver didn't install properly. Reinstalled OS.
  • Ubuntu 11.10. (from now all my tests happened on Oneiric) clean install, fglrx proprietery driver installed from repositories (I installed Catalyst 11.8., not the post-release update 11.9, as per this post, tried installing 11.9 too, but it didn't install properly, so I performed a clean OS installation again - yes I know I could have removed/purged fglrx, but I am obsessive-compulsive (and now getting pretty tired and desperate, too).)

  • Thought that I might need hardware acceleration, so I tried installing the packages

    sudo apt-get install xvba-va-driver libva-glx1 libva-egl1 vainfo

but realized that libva-egl1 wasn't in the 11.10. repositories, so I cannot show the output of vainfo.

My past: Have been an Ubuntu user (and missionary) for about 5 years, in the past few I have been using Karmic, which has become heavily outdated by now (especially lacking security updates), but for video playback I used the proprietary driver available from the ATI website at the time, and playback as well as fan and power management was just great. In MPlayer I used to use xv overlay. With glxgears I used to get over 3800 FPS.

If anybody is willing, let alone able to help, it is highly welcome and greatly appreciated.

  • So, the open-source drivers are not an option? Commented Jul 9, 2012 at 22:04
  • Read the information on this post: askubuntu.com/questions/74171/… specially the part where you need to remove the old drivers before installing the new drivers and try the 12.6 drivers, and 11.x version was just too buggy and bad (imho), the 12.x are proving to be nice. Let us know how it went. Commented Jul 9, 2012 at 22:09
  • Bruno, thank you for the quick reply. I haven't tried the open source ('radeon') drivers before installing fglrx, that was a mistake on my part, I will rectify that. As for the 12.6 driver, with my card the ATI site sends me to download 12.4, which does not install properly on my machine on 11.10. as I wrote in my original post, but I can give 12.6 a shot. Problem is, presently I am not 100% sure my machine takes advantage of the installed fglrx, since, as I wrote System Info specifies "Graphics" as "Driver VESA:M82".
    – Woland
    Commented Jul 9, 2012 at 23:02

2 Answers 2


It seems that at this point the best option for this ATI card is the open source driver, which works with these cards.

It provides excellent 2D and 3D acceleration and video playback seems to be flawless so far and even desktop effects are way smoother than with the fglrx driver from the 11.10. repositories.

To fully uninstall the already installed proprietary driver I followed this post (suggested by Bruno Pereira), but I checked this site as well.

Also, under "Graphics", System Settings >> System Info now displays this: "Gallium 0.4 on AMD RV620", which is just perfect.

Anyone having the same card is NOT recommended to install:

  • fglrx (post-release updates) from the 11.10. repositories (simply doesn't install properly)
  • fglrx from the 11.10. repositories (comes with the descibed problems)
  • fglrx 12.04. from the ATI site following the ATI Linux community wiki (doesn't install properly)
  • installing xvba-va-driver, libva-glx1 and vainfo was a waste of time, obviously, since my card (Mobility Radeon HD 3450) does not support UDV2 (its supported UDV version is UDV+). If you would like to check if your card supports UDV2 and is thus subject to 3D acceleration by installing the above mentioned packages (xvba-va-driver, libva-glx1 and vainfo) on top of proprietary fglrx, check here, under "availability."

I haven't tested 12.6. and unless I have to, I won't for a while: I've had my share of trial and error and reading forums for awhile.

What I'll be curious to see is power management (fan action and noise) of the open source drivers. Once I have substantial experience with that I'll post it here, anyone else is welcome to do the same (if it's allowed by AskUbuntu rules.)


Try disabling compositing in the window manager settings or x server config file. If you don't need the fancy effects this should not be an issue.

In xfce it's in settings manager -> window manager tweaks -> compositor tab.

In xorg.conf:

Section "Extensions"
    Option "Composite" "Disable"

I had the exact same problem, every tool reported that hw acceleration was working for video and 3d and still playback was choppy and cpu usage was high for 1080p videos. I have fglrx 15.201 from stock package on Ubuntu Studio 15.10 for my radeon hd 5770. The open source driver handled video playback cleanly, however it does not support opencl currently which I need.

Not sure yet why but it seems like compositing is done in software when the fglrx driver is used and works in hardware when the open source driver is used. This of course is a huge performance drain for full hd video playback. Mplayer logs a warning about compositing if it is enabled, can be useful for testing other playback issues as well because of the detailed messages it provides when you run it from a terminal window.

There should be a way to enable hardware accelerated compositing when using the fglrx driver but I don't know of it yet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .