My Ubuntu 12.04 box has been working fine. A recent update may have messed something up.

I normally run remote windows on it, and I noticed that my windows were failing to start up. I then tried logging into it directly from the GUI console, and I'm seeing that after I press enter on the (valid) password, the page just redisplays. It's not a password error, as that would give me an inline error. I see some messages appear and disappear quickly between the login screen going away and then redisplaying, but they go away too quickly to read.

I was able to run the non-gui login, and I did an update and upgrade, and then rebooted, but it's doing the same thing.

I have a Samba connection from my Windows box, and that's still working.

If it matters, here's my uname output (somewhat elided):

Linux ... 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

What can I do to troubleshoot this?

Note that when I select "Guest Session", it lets me log in and displays the window manager. This seems significant to me. Does this mean that something specific to my login is causing it to fail?

Note: If it matters, here's the output from /var/log/dmesg. The line about gdm seems interesting:

[    9.815883] Bluetooth: RFCOMM TTY layer initialized
[    9.815887] Bluetooth: RFCOMM socket layer initialized
[    9.815888] Bluetooth: RFCOMM ver 1.11
[    9.879088]  [PCSPP,TRISTATE]
[    9.879092] parport0: irq 7 detected
[    9.883935] type=1400 audit(1341871177.871:10): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper" pid=845 comm="apparmor_parser"
[    9.884365] type=1400 audit(1341871177.871:11): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/ntpd" pid=851 comm="apparmor_parser"
[    9.950397] e1000e 0000:00:19.0: irq 42 for MSI/MSI-X
[    9.961160] init: gdm main process (907) killed by TERM signal
[    9.966358] lp0: using parport0 (polling).

Some other useful information might be in what appears in /var/log/auth.log when I try to log in:

Jul 11 08:28:32 -hostname- lightdm: pam_unix(lightdm:session): session closed for user lightdm
Jul 11 08:28:32 -hostname- lightdm: pam_unix(lightdm:session): session opened for user -username- by (uid=0)
Jul 11 08:28:32 -hostname- lightdm: pam_ck_connector(lightdm:session): nox11 mode, ignoring PAM_TTY :0
Jul 11 08:28:32 -hostname- lightdm: pam_unix(lightdm:session): session closed for user -username-
Jul 11 08:28:32 -hostname- lightdm: pam_unix(lightdm:session): session opened for user lightdm by (uid=0)
Jul 11 08:28:32 -hostname- lightdm: pam_ck_connector(lightdm:session): nox11 mode, ignoring PAM_TTY :0
Jul 11 08:28:33 -hostname- lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "-username-"
Jul 11 08:28:33 -hostname- dbus[769]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.60" (uid=104 pid=14858 comm="/usr/lib/indicator-datetime/indicator-datetime-ser") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.16" (uid=0 pid=1329 comm="/usr/sbin/console-kit-daemon --no-daemon ")
  • I envountred same as thıs problem . İt perhaps originating from the compiz settings I thınk try thıs , who knows it ll work may be :) askubuntu.com/a/286774/190327 – user190327 Sep 5 '13 at 13:06

Ok, I figured it out. It was simply an error in my .bashrc. I finally saw my .xsession-errors file. It wasn't a recent change my .bashrc, but I recently changed my .profile to source it. I believe the problem is that I'm sourcing it from Bourne shell, so some Bash-specific stuff fails.


I reselected the window manager (Gnome) at the login screen. That's all it took to make logging in work for me without the redisplaying you describe.

There's an OK "bar" at the bottom of the list. After selecting Gnome, I clicked on that OK.


If you can, run "tail -f /var/log/dmesg" from the terminal, then swap over to the GUI and try logging in there. You may also want to try running in GNOME-2d

  • I don't know how I can do that. I can run the text console and run that, but how do I switch back to the GUI console to try logging back in? I tried gnome-2d, and that does the same thing. – David M. Karr Jul 9 '12 at 22:02

Also perhaps it can help:


 sudo dpkg-reconfigure lightdm

( then select lightdm, ok, reboot )

And if you use GNOME, just try login into Ubuntu2d mode and reinstall or fix your GNOME.

  • lightdm was highlighted. I moved the cursor till OK was highlighted, then I pressed Enter. That went back to the shell prompt. I rebooted, but it's still doing the same thing. I also tried logging into ubuntu2d mode, and it's doing exactly the same thing. I tried several of the other modes, and they also do the same thing. – David M. Karr Jul 9 '12 at 22:01
  • use Tab to select OK ... if you can run console, try also: sudo apt-get install -f it can fix broken packages. – swift Jul 9 '12 at 22:18
  • I was using Tab. OK was highlighted, and I pressed Enter. It just gave me the shell prompt back. That command line reported 0 changes (upgraded, newly installed, remove, not upgraded). – David M. Karr Jul 9 '12 at 22:23
  • dpkg-reconfigure just refresh configuration ... sudo apt-get install --reinstall -fmu lightdm .....maybe............ Other solution it is deleting old account from Guest session, and creating new one ... but WARNING for your files! – swift Jul 9 '12 at 23:16
  • ha ... GDM tries init, but killed ... some app with boot-time config that propose GDM ... – swift Jul 9 '12 at 23:23

Isntall Gnome Session Fallback:

apt-get install gnome-session-fallback

Then select "Gnome Classic" at login screen (with or without effects).


You can get the same symptoms, if your Xauthority file (~/.Xauthority) is somehow broken. Just delete/move it and you might be fine:

Desktop login fails, terminal works


For me somehow the .Xauthority files ownership had reverted to root:root. Changing the ownership back to my userid fixed the issue.

  • Please clarify how you have done it. – BuZZ-dEE Mar 6 '14 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.