I'm using notify-send to get notifications. Since yesterday, it stopped working. After a reboot, I could get a few messages through, but a minute later I can't any more. I have spammed it with a few hundred messages and killed it, but as I said - I've rebooted since.

Killing and restarting the Process at /usr/lib/notify-osd/notify-osd gives me a warning, "Another instance has already registered org.freedesktop.Notifications", and subsequently "Could not register instance".

Note that the notifications from Banshee come through no problem. It's - as far as I can tell - only notify-send that doesn't work properly; There isn't any output from it about what could be wrong either.

Here are the contents of ~/.cache/notify-osd.log

[2010-12-04T16:50:07-00:00, notify-send ] Test

[2010-12-04T16:53:35-00:00, notify-sharp ] Octopus's Garden
by 'The Beatles' from 'Abbey Road (2009 Stereo Remaster)'

Only the first one didn't appear on the screen; The command I ran was notify-send Test Hello.

The problem seems to be related to Totem, or at least any application - as DoR suggested - that inhibits the screen saver from being started.

Here's how to replicate the problem:

  • Start Totem, make sure "disable screen saver while playing [all]" is enabled
  • Let it play something for as long as the idle time-out for the screen saver
  • Try to notify-send

I can now reproduce the problem consistently, so I should really file a bug.

  • 1
    Was the screensaver inhibited in any way when you used notify-send? Have you tried using notify-send in a guest session?
    – Isaiah
    Dec 5, 2010 at 0:59
  • Yes the screen saver may well have been inhibited (via Totem); I have tried it in a guest session - it worked - but then the error only happens sporadically, it could've just been luck I suppose. Dec 5, 2010 at 1:32
  • Which error is that? Does notify-send ever return an error?
    – Isaiah
    Dec 5, 2010 at 1:47
  • It's broken again - I thought I was confused but it seems to be a real problem, and not an easy one to debug. :-) No, notify-send doesn't print anything, by error I meant 'problem', sorry. Updated my question with some new information. Dec 5, 2010 at 9:13

1 Answer 1


This is  Bug #402962 in notify-osd. It was reported in July 2010, there has been no progress so far.

Since Totem has no option to disable Inhibiting the screensaver completely, there currently isn't a way to work around this bug. Other applications, which have this options, should not cause any problems once it's disabled.

My thanks to DoR for pointing me towards the screen saver.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .