I had everything working fine, I use a number of openGL graphics software, example pymol, mgltools, vmd, ballview, rasmol etc.

All of these give the error:

Xlib:  extension "GLX" missing on display ":0". 

and fail to initialize.

I have an i7 asus k53s with nvidia gforce

I need these to do my work. I tried the umblebee fix, and just removing all nvidia drivers, or rolling back. I do not know why these were working then stopped, but did notice a new nvidia console in the mu which I assume was from enabling the automatic nvidia feeds, etc? I also played with the xorg, however have no clue what settings are valid. In addition, the display is 50% of the time not recognized now? It just gives a geeic 640x480 and I have to login and out 10 times to get it to return to a normal setting. When I try and set it manual, there is no other setting allowed from the settings menus, and the terminal changes just get re set every time I log out?


Completely disabling the Nvidia GPU , then installing bumblebee, plus mesa glx and gl libraries worked, however now I have a GPU which is useless. Thus, if anyone has a fix that allows use of the GPU, even if for other applications such as GPU accelerated software (CUDA or OpenCL) , or some graphics based applications. Otherwise it seems pointless to even have a Gforce on the PC, when everything seems to work perfect with ATI software, and now synaptic available openCL headers, etc...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.