1

I have been getting a very annoying problem since recently in Ubuntu 12.04, probably due to another update that did more bad than good...

When I resume from sleep on battery power my Lenovo Thinkpad T420, my wireless laser mouse (Logitech M705) freezes everytime I leave it for 2 seconds. It then starts moving again when I shake it for 5 seconds. The touchpad works normally.

I'm guessing the mouse enters some sleep mode and I'd like to know where to change this "timeout" value.

2 Answers 2

3

I found a solution on this page:

http://ubuntuforums.org/showthread.php?t=1675277

here's what I did:

in /etc/laptop-mode/conf.d/usb-autosuspend.conf

CONTROL_USB_AUTOSUSPEND=0

And everything works normal now.

2
  • Did you have to reboot for this to work?
    – naught101
    Jul 10, 2013 at 2:20
  • I rebooted, and it appears to have worked. I guess there's probably a way to restart it without rebooting, but I've always had trouble find out stuff like that for USB. Anyway, thanks for the research!
    – naught101
    Jul 10, 2013 at 2:30
0

I'm not sure which kernel module the mouse drivers are using (you could check that). There's the possibility to mark modules problematic to suspend/resume, having them removed at suspend - and reloaded at resume. This is done using the SUSPEND_MODULES setting, as e.g. described in this question. Worth trying.

2
  • Thanks Izzy, I've just edited the question, it no longer is a suspend/resume problem but a problem occurring only on battery power.
    – R Pennese
    Jul 11, 2012 at 7:48
  • Oh -- I see. But your new description seems even more annoying: 5s after resume only is something one can live with, but in the middle of work... Good luck for a fast solution!
    – Izzy
    Jul 11, 2012 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.