My connection was fine until now, but my wired connection is not working in Ubuntu 12.04. I have installed Ubuntu 12.04 along side Windows 7 partition and the connection works on Windows but not on Ubuntu 12.04. I have no problem with wireless connection as well. The problem is specific to the wired connection on Ubuntu 12.04. I have included a few details below.


eth0      Link encap:Ethernet  HWaddr 00:1e:ec:8d:f0:03  
          inet6 addr: fe80::21e:ecff:fe8d:f003/64 Scope:Link
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:376 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:316 (316.0 B)  TX bytes:33769 (33.7 KB)

eth2      Link encap:Ethernet  HWaddr 00:21:00:4e:ac:58  
          inet6 addr: fe80::221:ff:fe4e:ac58/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:1660 errors:0 dropped:0 overruns:0 frame:28
          TX packets:1846 errors:61 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1372676 (1.3 MB)  TX bytes:254576 (254.5 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1862 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1862 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:155767 (155.7 KB)  TX bytes:155767 (155.7 KB)

sudo lshw -C network 

       description: Wireless interface
       product: BCM4312 802.11b/g LP-PHY
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth2
       version: 01
       serial: 00:21:00:4e:ac:58
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion= ip= latency=0 multicast=yes wireless=IEEE 802.11bg
       resources: irq:18 memory:99700000-99703fff

       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 02
       serial: 00:1e:ec:8d:f0:03
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:19 ioport:3000(size=256) memory:93410000-93410fff memory:93400000-9340ffff memory:93420000-9343ffff
  • Go to Unity top bar select the connections , Select edit conntn >> In wired tab , edit the Auto Ethernet, then check if it is Tick Marked to connect automatically if not tick it, and remove the Tick Mark from Wirless Conntn. Check the wired connectn from Live Ubuntu Cd or Usb drive too. – atenz Jul 12 '12 at 10:02

I encountered the same problem after upgrading to 12.04.

The following solution worked for me:

  1. Open this file in a text editor as root:

    gksu gedit /etc/network/interfaces
  2. Add these lines to the file:

    auto eth0
    iface eth0 inet dhcp
  3. Save the file and quit the text editor.

  4. Now restart the network:

| improve this answer | |
  • also - was experiencing periodic DNS Failure through my ISP (Comcast) So I switched to Google DNS - which has improved my connection speed and decreased page loading errors to almonst 0. – Charles Morgan Oct 28 '12 at 3:02
  • My /etc/network/interfaces has the following content: auto lo iface lo inet loopback auto eth0 iface eth0 inet dhcp and going to edit connections -> wired connection -> ipv4settings -> Method -> Automatic did the trick. – Lavixu Mar 18 '14 at 8:23

All I had to do was unplug the ethernet cable from the port and plug it again. It worked. Ridiculous.

| improve this answer | |

Try to enable / disable the connections, also remove the currently active and add it another time!

| improve this answer | |

Try this...

Press Ctrl+Alt+T and type echo on | sudo tee /sys/class/net/eth0/device/power/control

After that, logout your machine, pull out the ethernet cable and then plug it in again after logging it in.

| improve this answer | |


sudo service network-manager restart

to reset IP then

sudo /etc/init.d/networking restart

After that Check


see what will changes.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.