I am facing some serious web page rendering issues with Chrome. It is more prominent during javascript based animations and stuff on websites like youtube. I have tried removing chrome using (sudo apt-get purge google-chrome-stable) and then reinstalling it. But the problems still persist. The same webpages work correctly on firefox on ubuntu and chrome on windows. The problem only shows up when I use chrome on ubuntu.

I think the issue has started after I updated to the latest version of Chrome. I have used Chrome previously on this machine without any problems.

I have attached a image that demonstrates the issue.

enter image description here

What could possibly be the problem?

PS: here's the output of lshw -c video:

   description: VGA compatible controller
   product: Madison [Radeon HD 5000M Series]
   vendor: Hynix Semiconductor (Hyundai Electronics)
   physical id: 0
   bus info: pci@0000:01:00.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
   configuration: driver=fglrx_pci latency=0
   resources: irq:46 memory:e0000000-efffffff memory:f0020000-f003ffff ioport:d000(size=256) memory:f0000000-f001ffff

Here's the output of lspci -nn: output of lspci -nn

  • 1
    Merely removing and reinstalling may not help if your profile is corrupted. You may need to remove your profile. It's often more likely that a problem with your profile or the extensions therein are responsible. Go through Create a new browser user profile.
    – user25656
    Jul 9, 2012 at 8:10
  • are you using some addon?
    – Web-E
    Jul 9, 2012 at 8:11
  • @Web-E: using a couple of extensions from google: Chat for google, Google mail checker 3.2, Google Reader notifier 1.3.1, Google Tasks 1.0, Google + notifications. Mostly stuff from the Chrome store. Jul 9, 2012 at 8:16
  • Try incognito Mode , and see if its still persists.
    – atenz
    Jul 9, 2012 at 8:21
  • @tijybba: still exists in incognito mode. Tried it. Jul 9, 2012 at 8:23

7 Answers 7


The issue was with the graphic drivers.

I downloaded and installed the latest driver from AMD and now everything looks fine.

Thanks to @tijybba.

  • I was having this problem as well on two different computers (one laptop, one desktop) both with an ATI card. Updating from the driver that ships with Ubuntu (8.960) to the latest from the link above (8.982) solved the problem. I'm actually surprised more people aren't having this issue.
    – Mike
    Oct 7, 2012 at 19:53
  • @sumit_gt I also seem to have the tearing issues. Alas my HD4870 video card is considered legacy now, and the latest video driver supported is 12.6. The driver itself runs fine, I even play games on Steam in Ubuntu. Same pages render correctly in Firefox, but run like crap in Chrome.
    – bioShark
    Jan 8, 2013 at 20:43
  • I'm with the same issue with native intel drivers... most commonly in GMail...
    – caarlos0
    Jun 3, 2013 at 13:14

For me, this helped:

  1. Download latest beta drivers from AMD website.
  2. Uninstall ATI drivers:

    sudo apt-get remove --purge fglrx
  3. Reinstall xorg:

    sudo apt-get install --reinstall xserver-xorg-video-radeon
  4. Reboot.
  5. Install new beta drivers:

    sudo sh beta_drivers_name.run
  6. Reboot and Chrome works fine.
  7. Remove "AMD testing use only" logo (optional): http://ubuntuforums.org/showthread.php?t=2076381
  • i face this issue too. i ll try to install latest beta drivers, and i hope their beta drivers do the trick!
    – Paschalis
    Jan 5, 2013 at 21:49

I resolved the problem by enabling the "tear free" option on the Catalyst Control Center:

System Tools → Preferences → AMD Catalyst Control Center → Display Options → Tear Free

  • Slows down graphics very hard, though.
    – frhd
    Mar 30, 2015 at 16:11

Have you considered using a ppa build of Chromium instead of Google Chrome? There is a ppa for it here.The latest development builds are here. These builds are meant to be the same as Google Chrome Canary, the experimental version of Chrome, that has great HTML5 support, but without some plugins, such as PDF, Flash, FFMpeg.

  • I voted this down because it doesn't attempt to answer the question. Plus, it refers to a ppa that is currently offering a significantly older version of Chromium.
    – user25656
    Jul 9, 2012 at 14:46
  • The reason I mentioned Google Chrome Canary is that many Chrome users haven't heard of it. If they knew about it, they might want to try it instead. I have updated the link - thanks for spotting that. You have a good eye!
    – user75798
    Jul 9, 2012 at 15:41
  • 1
    Even the updated link currently points to Chromium 18 whereas Chrome stable is presently version 20. Anyway, you may want to see this question about the Chromium ppa. As far as Canary goes, it may not be a good idea to recommend it unless a person wants to use a bleeding edge browser and, AFAIK, there are no Canary builds for Linux.
    – user25656
    Jul 9, 2012 at 15:58

The problem seems to be related to java scripting. A good example is the website www.nasa.gov. If you look at it using firefox it renders ok. Chrome does not seem to work correctly. Especially the script displaying scrolling pictures (in a jQuery tupe of fashion) dails. Other websites have problems in rendering forms correctly (e.g. you can't fill in name fields for instance).

Might it be related to the fact that those websites have a HTML4 header but in fact use html5 technology?

  • Nope, that is not the issue. I have mentioned in the question that the same webpages render correctly in Chrome on Windows. Also, I hardly think pages like YouTube would make mistakes in javascripting.... Jul 29, 2012 at 10:43

I had the same tearing problem as well as popping during audio playback with a Radeon HD 3450 after upgrading from Ubuntu 10.04 to 12.04. I tried the latest drivers from Ubuntu and ATI, and neither one worked, I think because it's now a "legacy" product. I couldn't enable Tear Free Desktop because I got an "insufficient graphics adapter memory" error.

This is what fixed it for me:

  1. Enable Canonical partner repository
  2. Install Flash from Adobe
    sudo apt-get install adobe-flashplugin
  3. In Chrome, browse to chrome://plugins/
  4. In the upper right side of the screen, click the + next to Details
  5. Scroll down to Adobe Flash Player, find the version with PepperFlash in the path, and click Disable

I had a kind of similar problem: certain webpages didn't loaded or took them a long time to load. of them was google.co.uk webpage. I went to the extensions and removed "Hola better internet" extension. My Chrome is superfast now.


Not the answer you're looking for? Browse other questions tagged or ask your own question.