I have a machine running Precise (12.04 x64), and I cannot mount my SMB drives. It used to work (a week or two ago) and I didn't touch fstab! The machine hosting the shares is a commercial NAS, and I'm not seeing anything that would indicate it's an issue with the NAS.

I have an older machine which I updated to Precise at the same time (both fresh installed, not dist-upgrade), so should have a very similar configuration. It is not having any problems. I am not having problems on windows machines/partitions either, only one of my Precise machines.

The two machines are using identical entries in fstab and identical /etc/samba/smb.conf files. I don't think I've ever changed smb.conf (has never mattered before).

My fstab entries all basically look like this:

//<share_path>       /media/<share_name>        cifs  credentials=/home/downbeat/.credentials,iocharset=utf8,uid=downbeat,gid=downbeat,file_mode=0644,dir_mode=0755 0 0

Here's the dmesg output on boot:

[   51.162198] CIFS VFS: Error connecting to socket. Aborting operation
[   51.162369] CIFS VFS: cifs_mount failed w/return code = -115
[   51.194106] CIFS VFS: Error connecting to socket. Aborting operation
[   51.194250] CIFS VFS: cifs_mount failed w/return code = -115
[   51.198120] CIFS VFS: Error connecting to socket. Aborting operation
[   51.198243] CIFS VFS: cifs_mount failed w/return code = -115

There are no other errors I see in the dmesg output.

Again, it used to work; now it doesn't. Very similarly configured machine works (but some packages are out of date on the working machine). The NAS has only one interface/IP address, nmblookup works to find it's IP from it's hostname (from the machine with the issue) and it responds to a ping. Please any help would be great.

3 Answers 3


I found that switching off IPv6 solved a very similar problem for me. My Ubuntu 12.04 box is hooked up to an enterprise network dominated by Windows users and I don't have any authority over the server. Following the tutorial at http://www.noobslab.com/2012/05/disable-ipv6-if-your-internet-is.html solved my problem. (Save a click: Edit /etc/sysctl.conf to insert three lines of the form "net.ipv6.conf.*.disable_ipv6 = 1", replacing * with "all", "lo", and "default"; then give the shell command "sudo sysctl -p".)


My internal IP ended up in my NAS's blocklist. I removed it; problem solved. Used smbclient to troubleshoot.

EDIT: I am much more familiar with GNU/Linux these days, and if I were attempting to debug this today, I would check out hosts.deny and iptables, one of which (or both) is likely used to implement the blocklist/blacklist in my now decommissioned commercial NAS.

  • For me it was a firewall filtering TCP. Using tcpdump I noticed that the mount is using port 445/TCP and 139/TCP and the TCP/SYN packets were not receiving any answer. Sep 21, 2016 at 19:36

In my case, the Windows machine I was trying to mount a shared drive from had suddenly decided it was on a public network, and was blocking all access. Telling it the network was private allowed me to connect again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.