I've recently encountered the following error message:

mount: mounting /dev/disk/by-uuid/3f7f5cd9d-6ea3-4da7-b5ec-**** on /root
failed: Invalid argument
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target file system doesn't have /sbin/init.
No init found. Try passing init= bootarg.

Busybox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
Enter 'help' for a list of built-in commands.
(initramfs) _

I run sudo fsck /dev/sda2 which is the Ubuntu ext4 root partition via LiveCD. It checked and fixed the file system. The next time I boot, Ubuntu started to load with the Ubuntu logo and the dots underneath for several hours (with the mouse pointer active on the screen), I even let the computer on overnight but still it did not successfully boot or got to the login screen in the morning.

I booted again with the LiveCD and checked the NTFS partitions with ntfsfix and again the NTFS partitions was checked and fixed successfully. I also edited my fstab and commented out the lines that auto-mounts the NTFS partitions. The next time I boot, it took almost 20 minutes for Ubuntu to get to the login screen, after typing the password it took an additional 10 minutes for Ubuntu to get to the desktop. On the desktop, it take several minutes to open any program, displaying the Dash alone takes 5 minutes!

Is there a fix for this without having to reinstall Ubuntu? I don't see or get any errors, Ubuntu is just taking too long to boot and to run programs. Please help!

  • 1
    You can press <kbd>Esc</kbd> to drop from "the dots" to a screen that actually says what Ubuntu is doing as it is booting up. Doing so might give more information about exactly what is going wrong. – adempewolff Aug 21 '12 at 1:57

Please download and burn the Ubuntu 12.04 Desktop ISO to a CD-R. Then set your BIOS to boot from it, and boot the Live-CD.

Once in there, open a terminal with Ctrl-Alt-T, and type sudo fdisk -l to see what the hard disk was mounted as.

Then run sudo fsck /dev/sda1, etc. for all partitions on that hard disk.

That should hopefully fix the problem.

  • Is it necessary to boot with same version of LiveCD? I have a Lucid Lynx LiveCD and tried to boot into it. It started loading and I saw the Ubuntu logo and the white dots underneath, and after a few minutes it went straight to a black screen, I've waited for almost 30 minutes but nothing happened. – Peachy Jul 8 '12 at 15:21
  • I was able to boot to a liveCD and run fsck on the Ubuntu root partition, it was fixed but I still cannot boot into Ubuntu. At first, it starts to boot, with the Ubuntu logo and the small dots changing colors underneath it but after 10-20 minutes the dots would stop moving and it would just stay as it is. I've waited for almost an hour still nothing happens. – Peachy Jul 9 '12 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.