I just updated Ubuntu about 15 minutes ago on my desktop which is running 12.04. Within the set of updates, there were some kernel upgrades. It didn't say I needed to reboot after the update was finished, but I thought I would anyway.

The computer successfully rebooted up to the login screen. However, after entering my password, the screen goes black for a moment, then it comes back to the login screen.

I tried the suggestions in this question, but unfortunately they didn't help. In the accepted answer, the questioner vaguely says it was a "Unity problem". I'm using Gnome-classic with full Compiz effects. I tried uninstalling and reinstalling Compiz, but that didn't fix anything.

So... I can't use my desktop computer until this is fixed. I hope there is some help soon.

I've uploaded the output of cat /var/log/Xorg.0.log to Pastebin.

A temporary solution of changing to gdm instead of lightdm was found with help in the chat room.


Somebody asked me that same question the other day :

since yesterday my ubuntu 12.04 locks me out, i can only access the guest account.
if i enter the correct password for the admin account,
the screen turns black and then goes back to the log in screen.
if i enter an incorrect password, it says incorrect password.
if i create a new admin account via the guest account, i get the same problem.
resetting the password won't help :(
any ideas anyone?

It seem's a few people have had this problem, and using gdm instead of lightdm is the recommended workaround, and it worked for the person that asked me - after a couple of reboots. Have a look at these links for instructions & let me know if it helps.


Can't log in to ubuntu 12.04


| improve this answer | |
  • As mentioned in the question, I got some advice in chat that said basically the same thing, so it seems this is the way to go. I ran sudo apt-get install gdm, which brought up a dialog to select gdm instead of lightdm, and then it was possible to log in. – Questioner Jul 8 '12 at 15:26
  • Glad it helped you too, and thanks for the feedback. :o) – Fernhill Linux Project Jul 8 '12 at 15:28

Is it possible that your graphics card is not supported or isn't updated anymore, or something is not supported/became corrupt in the update? Use alt+F2 to drop back to a console in the login screen, log in as root, see if you can: sudo apt-get upgrade + sudo apt-get update to see if that will correct something that needed correcting. It's not very likely, but it's worth a try.

Maybe try to re-install your graphics driver this way as well. Additionally, maybe you should try a package update or repair with GNOME in case the issue lies in the desktop-environment itself.

Lastly, maybe this link will help you out: How To Fix Broken Packages In Ubuntu Or Debian

Hope you get this sorted out.

| improve this answer | |

The description alone is not enough for me to decide of the exact cause, but I can offer some help in diagnosing and fixing the problem.

First, you should be able to login into a text terminal without having to start your window manager.

Click CTRL-ALT-F1 to get access to one of your virtual terminals (to go back to graphical: usually CTRL-ALT-F7 should get you back into the graphical login screen gdm, kdm, or whatever you are using). Once in a virtual terminal, you should be able to login and get a shell.

Once in, look at the logs, in particular your window-manager logs and the X11 logs under /var/logs/... to figure out the cause of the failure of your window manager. HTH.

| improve this answer | |
  • Thanks for responding. I looked at /var/log/Xorg.log, but there were no errors in it at all. I dont know which other log files would be relevant, if any. – Questioner Jul 8 '12 at 4:57
  • I think it should be /var/log/Xorg.0.log. Also: 'ls -ltr /var/log' would show the most recently modified files under /var/log at the end of the list, so you can walk backward from that list. – arielf Jul 9 '12 at 6:14

Even though this is an old thread, if anyone is having this problem and looking for a answer, see the link below where the same question was answered well with an easy fix.

Ubuntu gets stuck in a login loop

| improve this answer | |

After you get a login screen, press Alt+Ctrl+F1 and log on. Then log on as root (you'll be asked for you password):

sudo su

Then try these commands one after another:

gdm stop

less /var/log/gdm/\:0-greeter.log

cd /var/lib/gdm/

mv .config/ .config-bkup

ls -ltr

service gdm stop

apt-get install gnome-session

apt-get indicator-applet-session

apt-get install indicator-applet-session

service gdm status

cd ~

mv .ICEauthority ICEauthority-bkup

{don't remove these file just backup}

mv .Xauthority Xauthority-bkup

service gdm start

Reboot is not necessary, if it asks for reboot:

init 5 / reboot
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.