Last night I tried to upgrade from Ubuntu 11.10 to 12.04. The upgrade process had numerous errors, but I let it continue assuming that it would safer than interrupting it. Near the end, two conflicting messages appeared: "too many errors" and there was also a message telling me that the system was upgraded nonetheless. The only option I was presented at that point was to reboot, which I did, but the reboot just hanged. Then I tried to boot under "recovery mode" but the system gets into an infinite loop with the message. So I tried to re install from 10.10, which went OK, including updates. Then I upgraded to 11.04 (which I had done before) and the system fails to reboot after the update.

CPU: AMD FX-6100 Zambezi 3.3GHz Socket AM3+ 95W Six-Core MOBO: ASUS M5A97 AM3+ with Bios Version = 1208, which is the most updated as of 2012.05.25 Video Card: EVGA 01G-P3-1556-KR GeForce GTX 550 Ti

Is there a compatibility problem caused by having an nVidia GeForce graphics card with an AMD CPU?

1 Answer 1


I also had this problem when I was upgrading. As far as I know, it has nothing to do with the graphics card. To fix this, you need to have a bootable Ubuntu Live USB or Live CD. Once you have booted into Ubuntu from the Live CD/USB, run the following command in the Terminal: sudo apt-get install gparted. After you have installed Gparted, open it up from the Dash, and select your hard drive from the top right-hand corner of Gparted.

enter image description here

Your screen should look something like the image above. You need to locate the partition that you have installed Ubuntu on. The filesystem of the partition should be ext3. In the image above, the partition Ubuntu is installed on would be /dev/sda3, because the filesystem is ext3. Now the you have found the partition that you have Ubuntu installed on, you need to run the commands below in the Terminal. Make sure to replace /dev/sda1 with the Ubuntu partition you saw in Gparted.

sudo mount /dev/sda1 /mnt/myroot

sudo mount ‐‐bind /dev /mnt/myroot/dev

sudo mount ‐‐bind /proc /mnt/myroot/proc

sudo mount ‐‐bind /sys /mnt/myroot/sys

sudo chroot /mnt/myroot

Now, run apt-get install -f. This should fix the errors encountered before, and complete the upgrade. Once apt-get install -f has finished running, you can reboot your computer and remove the Live CD/USB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.