30

I work with Xubuntu 12.04 and use Okular (version 0.14.3) to view pdf files. If I click a web link in a pdf file (created with "pdflatex" using the "hyperref" package), "Abiword" (It's a word-processing software, like Libreoffice writer) is opened instead of my default browser google-chrome. How can I change this behavior? The settings in Okular do not seem to provide a solution.

(Note that I set google-chrome as the preferred application for web browsing under Settings -> Preferred Applications, so that's not the problem).

  • Is this happening only with okular? Have you tried any other pdf viewer such as evince? – Anwar Jul 13 '12 at 6:30
32

The answer by @Marius is correct. It helped me. Just a clarification.

  1. Run kcmshell4 filetypes in a console or by Alt+F2. File Associations - KDE Control Module will open.
  2. Search for html and select the file type text/html.
  3. Move the application name you want to be a default for html in the "Application Preference Order" to the top.
| improve this answer | |
  • 1
    unfortunately, this doesn't do the trick for me... for html, Firefox is first option, but still not opened. Seems like the Firefox entry is somehow invalid, it is skipped. No idea how to "fix" it, though. – codeling Mar 7 '19 at 16:30
  • @codeling, the solution still works for me. I am on Linux Mint 19. – djhurio Mar 17 '19 at 14:20
15

For newer KDE versions you might need to run:

kcmshell4 componentchooser

and set the "Web Browser" to the command of your preferred browser.

This worked on Arch Linux, at least.

| improve this answer | |
  • 1
    This worked for me too! (I'm on Openbox on ArchLinux) – Abhinav Jan 15 '16 at 19:58
  • This worked for me on Kubuntu 16.10, after adjusting filetype and default browser settings didn't, which makes me wonder what the point of those other two is. Is there some way, opaque to em, in which all these settings should be used to work and play nicely together, rather than contradict and override? – Mark Mar 4 '17 at 11:42
  • Works perfectly for Okular in Lubuntu 16.04, while the kcmshell4 filetypes way didn't. – dessert Dec 4 '17 at 11:01
5

The answer can be found in the okular devel list here

The important part is quoted here

Is it linking to an html file? If so you might want to also check which is the default application in kcmshell4 filetypes for html mimetype.

| improve this answer | |
  • 3
    Though theoretically the answer may be correct. But it is preferable to include the necessary details here. – Anwar Jul 13 '12 at 6:32
0

I am using Ubuntu 18.04 and for me it finally worked:

  1. running: kcmshell4 filetypes
  2. selection the File type: inode/vnd.kde.service.http and adding the Firefox to Application Preference Order.

I think that addition of text/html (as suggested in the previous answer) was not enough because not all links in pdf files have the filename pattern *html

| improve this answer | |
0

I did the above -- moved my chosen browser to the top but it still opened in the browser I did NOT want. What solved it was to choose 'remove' to delete the browser that I did not want to use. That fixed it for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.