7

Recently the speakers have suddenly started to make popping noises every few seconds, although it can pause for irregular amounts of time. The sound is like that of when you plug/unplug headphones from a socket.

I have tried blowing in the headphone socket but with no outcome.

This seemed to come from nowhere as I haven't kept my laptop in a dusty/dirty place recently or had any software changes.

8

Check this out too if the above answer doesn't work for you.


This is the actual method that the link contains:

Run this command (providing you have nano installed, per default you have):

sudo nano /usr/lib/pm-utils/power.d/intel-audio-powersave

Find the line:

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

Comment it out using "#". Underneath add the line:

INTEL_AUDIO_POWERSAVE=false

Save and exit, then restart.

If you don't have an Intel HDA sound card, you're all done. Otherwise:

sudo sh -c 'echo N > /sys/module/snd_hda_intel/parameters/power_save'
sudo sh -c 'echo N > /sys/module/snd_hda_intel/parameters/power_save_controller'

Now you can make these changes permanent by running:

sudo chmod -w /sys/module/snd_hda_intel/parameters/power_save
sudo chmod -w /sys/module/snd_hda_intel/parameters/power_save_controller
|improve this answer|||||
  • 1
    Thanks for the update, but for power_save you need to echo 0 as echo N gives I/O error – Ibuntu Jan 6 '15 at 15:25
  • Also, sudo chmod -w /sys/module/snd_hda_intel/parameters/power_save_controller does not work to keep the file from being written to. Every time I restart my system the value is changed back to Y – Ibuntu Jan 6 '15 at 16:54
  • whenever I have permission problems with sudo.. I use sudo su. try it. then run the command. – Bhikkhu Subhuti Apr 30 '16 at 4:08
  • Besides fixing the popping noise, this also fixes the humming noise when power saving is active. – octoquad Sep 16 '19 at 16:31
  • echo N > /sys/module/snd_hda_intel/parameters/power_save failed for me with "Invalid argument", however echo 0 > /sys/module/snd_hda_intel/parameters/power_save worked perfectly. – Mira Weller Nov 1 '19 at 16:17
9
  1. Open a terminal and run:

    alsamixer -c0
    
  2. Press F6 and select your sound card (in my case HDA Intel PCH).

  3. Go towards the right and disable Auto-Mute M.

This worked with a Lenovo Y 410P.

|improve this answer|||||
  • 1
    disable loopback (on the far right) instead of Auto-Mute worked for me (I'm using dell inspiron 5548) – Nir Duan Apr 8 '17 at 16:43
  • 1
    I can confirm disabling loopback solved this issue for me as well. I kept Auto-Mute on. – JaredL Jun 22 '17 at 5:07
  • How would you make this permanent? e.g. what commands to add to /etc/rc.local ? – EoghanM Sep 12 '19 at 15:54
  • Also just a note that the popping likely comes from the output being re-enabled after auto-mute, so if the output is muted and you disable auto-mute, you might still hear one more single pop afterwards (which will lead you to believe that this answer didn't work) – EoghanM Sep 12 '19 at 16:00
2

I am shooting in the dark without knowing anything about your hardware.

First, try disabling your microphone in Volume Settings and see if that does anything. If not, I have one more suggestion. Open Terminal, and type:

gksudo gedit /etc/modprobe.d/alsa-base.conf

Change the power_save line from:

options snd-hda-intel power_save=10 power_save_controller=N

to:

options snd-hda-intel power_save=0 power_save_controller=N

If your microphone was not picking up feedback, causing the popping, then the second solution should do the trick.

*Note, if your .conf file says something different, leave everything else the same, and change only the power_save portion*

|improve this answer|||||
  • For some reason my Microphone doesn't show up in the volume settings, there are no input devices at all, I'm sure I've seen it before, could this have something to do with it? – Ross Fleming Jul 9 '12 at 17:06
  • And I also can't find a power save line in that file, thankyou for your help though, it's much appreciated – Ross Fleming Jul 9 '12 at 17:24
1

Open a terminal and run:

alsamixer -c0

Press F6 and select your sound card (in my case HDA Intel PCH). Go towards the right and at the end disable Loopback Mixing

That worked for me, not the microphone thing

|improve this answer|||||
0

The steps in this answer: https://askubuntu.com/a/195800/108121 from the (more detailed) question post Periodic clicking sound from PC speaker worked for me. I am running Natty on a Lenovo T61.

Some users who experience the popping noise when using Chrome report that disabling the "Pepperflash" plugin solves the popping noise problem for them [source].

|improve this answer|||||
  • 2
    The problem seemed to just disappear once I updated chrome and Ubuntu on my T61 and IdeaPad S10-3. But thanks anyway! – Ross Fleming Nov 16 '12 at 16:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.