I want to change the font in the login screen - where is the configuration for that?


I will recommend the two best ways to change the default font of lightdm. Open terminal and run the command pkexec lightdm-gtk-greeter-settings if it doesn't work for you, you need to install it manually using the command sudo apt install lightdm-gtk-greeter-settings and after installation , run pkexec lightdm-gtk-greeter-settings.A window will appear where you can configure the lightdm.

enter image description here

Another method is to change edit the conf using the dconf-editor. Open dconf-editor and search greeterfrom the search box

enter image description here.

Click on the first option that appears and configure all your lightdm settings there.

If you don't have dconf-editor installed , install it by sudo apt install dconf-editor

This is not the answer for question asked 8 years ago but for the current users who are facing this problem.

  • Thanks for the answer. Not bad, and cool desktop gadget/widget. – gabeweb Jul 26 '20 at 18:56

Start by opening up a terminal, start typing "terminal" in your unity dash to see the option or press ctrl+alt+t

Lets go to the correct directory:

cd /etc/lightdm

Now lets make a backup of the file before we make any changes:

sudo cp unity-greeter.conf unity-greeter.conf.bak 

Now we need to open up this file and see whats changed, type/copy this:

gksu gedit /etc/lightdm/unity-greeter.conf

The file should look like below:

# background = Background file to use, either an image path or a color (e.g. #772953)
# logo = Logo file to use
# theme-name = GTK+ theme to use
# font-name = Font to use
# xft-antialias = Whether to antialias Xft fonts (true or false)
# xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
# xft-hintstyle = What degree of hinting to use (hintnone, hintslight, hintmedium, or hintfull)
# xft-rgba = Type of subpixel antialiasing (none, rgb, bgr, vrgb or vbgr)
font-name=Ubuntu 11

Then save and log out.

  • Hi, thanks for the reply, but still the default font (Ubuntu). I put Segoe 11 (font Segoe, size 11), but has no effect on restart. – gabeweb Jul 8 '12 at 17:11
  • 3
    All the unity-greeter settings were moved to gsettings, at least during 12.04 and maybe before. This info is now outdated. – mfisch Nov 30 '12 at 23:28

In case you want to customize your Display manager lightdm may not be the ideal choice. I would replace it with mdm (themability, graphical configuration tools, etc) , which is a bit more bloated but you won't notice any difference except it's running on a 12 year old notebook. Instructions to do so can be found here: How can I replace LightDM with MDM?


You can try the method mentioned here: https://askubuntu.com/a/224060. This command will complain "No protocol specified" but should work (omit exclamation mark in the end of the command). Though it changes only the font of the top panel in greeter.
Also you can get the list of other settings which can be adjusted with this method:

sudo -u lightdm dbus-launch gsettings list-keys com.canonical.unity-greeter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.