11

I had recently installed VMware 4.0+ on my Windows 7 Home Premium machine. I installed Ubuntu 12.04 LTS on it. However, when I turn on my VM, Ubuntu doesn't run in full screen mode. Moreover, the performance of VMware is a bit choppy and not all that smooth.

I have a full HD display with 1920x1080 in my Windows 7 system. I want to be able to run Ubuntu with the same resolution.

11

If the automatic mode fails yo could try with xrandr in a console to see which resolutions Ubuntu supports. It will give you something like this:

$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
VGA1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 410mm x 230mm
   1366x768       59.8*+
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  

And then:

$xrandr -s  1366x768
|improve this answer|||||
  • Manually adding a screen resolution in a VM running on VMWare Player makes the guest CPU go up to 100% and finally crash after about 10-15 seconds. – Daniel Jan 13 '16 at 9:09
8
  1. Enable 3D acceleration in VMware.
  2. Set the Display option to "AuTomatic"/"host screen"
  3. Install VMware tools in Ubuntu to enable dynamic screen resizing.
  4. Use Ctrl+Alt+Enter to enable/disable full-screen mode.
|improve this answer|||||
  • 1
    Sometimes just installing VMware Tools is enough. – Eliah Kagan Jul 6 '12 at 16:48
  • This setting doesn't exist for me (VMware Workstation 12 Player, 12.1.1), but instead I checked the Virtual Machine Settings -> Options -> Power -> "Enter full screen mode after powering on" checkbox. – jtpereyda Jul 14 '16 at 17:54
1

This seems to be a bug related to either VMWare or the xorg module in Ubuntu. More information can be found here. In my case, this issue arose because I dock to a monitor at work that is 16:10, instead of 16:9 on my laptop screen. I was able to utilize a workaround (mentioned by Karan in above link) whereby I left full-screen mode with Ctrl-Alt-Enter and then reentered full-screen mode by pressing that again with my 1920x1080 resolution restored. Hopefully this workaround continues to work.

|improve this answer|||||
1

Update Ubuntu to the latest version 13.10 32 bit (as it is less resource hungry) and update your vmware player to the latest version as it is free:

https://my.vmware.com/web/vmware/free#desktop_end_user_computing/vmware_player/6_0

And then enable 3D acceleration and install vmware tools:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1022525

|improve this answer|||||
0

For my version of VMWare Player, 12.1.1 build-3770994, there is no Display option for "Automatic"/"host screen".

Instead, I:

  1. Installed VMWare Tools. I was on Ubuntu 16.04 and open-vm-tools-desktop worked best for me. See this question.
  2. Checked the Virtual Machine Settings -> Options -> Power -> "Enter full screen mode after powering on" checkbox.
|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.