Last night I tried to upgrade from Ubuntu 11.10 to 12.04. The upgrade process had numerous errors, but I let it continue assuming that it would safer than interrupting it. Near the end, two conflicting messages appeared: "too many errors" and there was also a message telling me that the system was upgraded nonetheless. The only option I was presented at that point was to reboot, which I did, but the reboot just hanged. Then I tried to boot under "recovery mode" but the system gets into an infinite loop with the message

/lib/recovery-mode/recovery-menu: line 109: /lib/recovery-mode/options/whiptail: No such file.    

I am at a loss. Any help is greatly appreciated. Thanks.

1 Answer 1


I got zero replies, but I fixed the problem, sadly by re installing from scratch from the Ubuntu-10.10-AMD6 DVD

This time I set up partitions manually to something like this:

/boot primary ext4 512MB

/ primary ext4 150GB

swap ext4 100GB

/home logical ext4 remaining GBs

Immediately after the install the system warned me that 10.10 was no longer supported and asked me to update and then to upgrade to 11.04. After the updates I rebooted the system, then issued the command

sudo apt-get install nvidia-new

rebooted, and then upgraded to 11.04 . When the upgrade to 11.04 ended, I rebooted, went to system settings/Additional Drivers, where I saw that the nVidia accelarated graphics was activated “but not in use”. I played to mae the dual-monitor system work,

Then I upgraded to 11.10, rebooted, did the updates, re installed tools I was using.

I am NOT TOUCHING 12.04 until I have evidence that the AMD FX-6100 MOBO works with the nVidia GeForce 550 Ti card works

So I am posting this response hoping to save for other people the countless hours I wasted.

  • 1
    You've set up swap to 100GB? That's too much. The recommended swap space is twice the amount of physical memory (RAM).
    – Peachy
    Jul 15, 2012 at 1:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.