I had installed and loved AWN, and had removed my last panel using these instructions. Everything was wonderful. However, apparently I was using an AWN package for Lucid - I'm on Maverick. After a recent run of the update manager, AWN was removed, and I now have no access to anything - can't get at any of my applications or folders. The only reason I'm able to even write this message is because I had installed the unity netbook packages to play with, so I restarted and booted into a netbook edition session.

Can someone help me get my desktop edition back? Is there a keyboard shortcut I don't know about to run a terminal window? I assume if I could get into terminal, I could reverse the instructions about hiding the last panel, and once I have a panel I could add the applications menu back, and then from there try to find a version of AWN that works on Maverick.

EDIT: Javier's answer below did get me back into the GUI with a panel that I was able to add the applications menu to. However, here's what I found. When I go into the software center to install AWN, it turns out I had previously installed it using a PPA that I found on launchpad, called PPA for AWN Testing Team (that's what shows up in the software center.) When I try to install AWN directly through the software center, it tells me I need to remove several packages that apparently got left behind (libawn1-trunk, python-awn-extras-trunk, and python-awn-trunk.) When I go into the PPA in the software center, I do see those packages, but clicking Remove doesn't actually do anything. It's like they're stuck. I tried to get into Synaptic to remove the packages from there, but when I try to run it from the applications menu, I get this error:

Failed to run /usr/sbin/synaptic as user root.

Unable to copy the user's Xauthorization file.

How can I get rid of those packages so I can reinstall AWN directly from the software center?

  • what are the permissions of your .Xauthority file? – RolandiXor Dec 3 '10 at 16:00
  • I don't even know what .Xauthority is; where do I find it? – EmmyS Dec 3 '10 at 16:09
  • It's a hidden file in you home dir. In Nautilus choose View->Show hidden Files. – Javier Rivera Dec 3 '10 at 16:28

You can usually use CTRL+ALT+T to open a new terminal, but I suspect that it wont work if gnome-panel is disabled.

You can use CTRL+ALT+F1 to move to a virtual terminal. You will nedd to log in, and then type this command.

DISPLAY=:0 gnome-panel &

Afterwards you should use CTL+ALT+F7 (sometimes it's F8) to get back to the GUI, the panel must be there. You should be able to restore your system now.

  • This worked; edited main post with more info since the comments field isn't big enough. – EmmyS Dec 3 '10 at 15:46
  • OK, I think I got it. I couldn't remove the packages from the software center because I couldn't log in as root. I came back into Unity, ran the software center, and when I tried to remove the packages, it did ask me to log in and removed the old packages. I then installed the new AWN packages. I'm going to restart and switch back over to a desktop session; hopefully this will let me get my AWN back to the way I had it before. – EmmyS Dec 3 '10 at 16:15

Assuming you are using a gnome session, you can launch any application with: ALT-F2, from the run dialog type: "software-center" . AWN is available for maverick from the official repositories.

  • Aren't Alt+F1, Alt+F2, etc bound through gnome-panel? I seem to remember that at some point the past when gnome-panel wouldn't load, I couldn't access the run dialogue. – Oli Dec 3 '10 at 15:24
  • This is not going to work, ALT+F2 only works if gnome-panel is running (AWN user without panel here ;). – Javier Rivera Dec 3 '10 at 15:24
  • I believe gnome-session keeps gnome-panel running even if you don't have any panel on the desktop. – João Pinto Dec 3 '10 at 15:27
  • Ooppps, Oli answered first. – Javier Rivera Dec 3 '10 at 15:28
  • I'll give all of these a shot and see what works. Thanks. – EmmyS Dec 3 '10 at 15:30

Ctrl+Alt+F1 will dump you in a proper terminal. You should be able to install things using sudo apt-get install xxx.

You might find aptitude a useful thing to have in a situation like this (sudo apt-get install aptitude if you don't have it already) as it'll let you search for packages in quite a nice little text-mode interface.

If you need to run a graphical application from a proper terminal (proper name: TTY) you might find you get errors about not being able to find the display. You can fix this by running export DISPLAY=:0. This would be handy for loading AWN without having to restart.


The easiest way to sort it out would be to right click on your desktop and select Create Launcher... from the menu type gconf-editor in the command box and give it a name so that you can remember what its for. Hit the ok button click on the icon and go back though to the gnome/session/required_components and change panel back to gnome-panel. close restart login hey presto panels are back. It depends on how many users use the computer other than you but having a short cut to a terminal on the desktop can be a life saver if you are "experimenting".

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.