269

This issue came up recently for me (and I've been prompted to lodge it as a specific question about it):

My system is not dual-boot, I run a standard Ubuntu desktop system "on the metal" (I think running it in a VM is the same).

Pressing c while booting does not cause the GRUB menu to appear (which I believe it does for a dual-boot system).

How can I get the GRUB-menu to present itself on a single-boot system?

  • 22
    +1 excellent question to expose an essentially undocumented feature of Ubuntu boot process, the answer to which I only found by accident while groveling through grub.cfg. Thanks for hoisting this up to the top (Googleable) level. – msw Dec 3 '10 at 15:29
  • 5
    Credit where credit is due... This issue came up in another question of mine (buried deep in the comments). Jorge Castro suggested that it would be a good idea to present as a question it its own right... (so credit to him.... and I'm happy to bask in the reflected glow ;) I can see the value of it being a primary Q/A. – Peter.O Dec 3 '10 at 15:45
246

Menu will appear if you press and hold Shift during loading Grub, if you boot using BIOS. When your system boots using UEFI, press Esc.

For permanent change you'll need to edit your /etc/default/grub file -- place a "#" symbol at the start of line GRUB_HIDDEN_TIMEOUT=0.

Save changes and run sudo update-grub to apply changes.

Documentation: https://help.ubuntu.com/community/Grub2

  • 4
    @codeMonk: Oops! (I've deleted my previous comment because I was on the wrong track)... I originally misunderstood the context of "GRUB_TIMEOUT=0". The context you mean is in relation to the "permanent" display of GRUB-menu... I thought you meant in relation to the "Shift" key method... It is true that for a permanently recurring display, you need both "#GRUB_HIDDEN_TIMEOUT=0" and "GRUB_TIMEOUT=*NON-ZERO*", as described in the link in the answer ... (I've just test it both ways.) – Peter.O Dec 3 '10 at 17:24
  • 6
    Holding left shift didn't work for me :( – Nick Apr 30 '17 at 22:31
  • 5
    In Ubuntu 18.04 there is no GRUB_HIDDEN_TIMEOUT=0 line in my /etc/default/grub - instead there is GRUB_TIMEOUT_STYLE=hidden (Shift during boot never worked for me (Dell?)). Any idea what to do? – jena Aug 22 '18 at 9:10
  • 2
    @jena I found the advice at the top of /etc/default/grub helpful: i.e., to have a look at info -f grub -n 'Simple configuration'. This explains the options. Use GRUB_TIMEOUT_STYLE=menu to have the menu shown. Or press ESC if you keep the setting at hidden but want to see the menu. – bovender Feb 18 at 10:18
  • 3
    Grub changes with each release, please consider adding version informatoin. The fact for example that this works only for 14.04. It sure is not relevant anymore for 18.04 – onknows Apr 12 at 18:18
75

I have tried both the Shift and Space keys but nothing works. Only the Esc key works for Ubuntu 14.04 and 16.04 to get Grub Menu at boot time.

  • 2
    same here. Only ESCAPE key worked with Ubuntu 14.04. – atmelino Dec 17 '15 at 4:52
  • 15
    The same for Ubuntu 16.04 - only Escape works. This should be mentioned in documentation (Recovery Mode) – matandked Apr 23 '16 at 13:30
  • 2
    Ubuntu 14.04 here. NOTHING works. – yPhil May 16 '16 at 23:25
  • 1
    Shift key works fine on my v16.04 . – Sopalajo de Arrierez Sep 26 '16 at 20:56
  • 7
    I had to repeatedly press the ESC key, not hold it down. Let's have 6 ways to do the same thing. Linux is fun. – Jeffrey Blattman Feb 23 '18 at 23:37
16
  • Keep hitting Shift until you see "Grub Loading Message"
  • After the message, hold the Shift down until the menu appears.
  • This is the nuance that helped me finally get in! Thank you! :) – ATSiem Oct 24 '14 at 3:35
  • 3
    That so does not work for me. No matter what I do to this poor SHIFT key, this Intel NUC skips the grub menu :( – yPhil May 16 '16 at 23:22
  • 2
    @yPhil Intel NUC is the freak who eats Shift. It works everywhere else. I'm lucky that Esc works for my NUC, but it didn't seem to work for you, did it? – Franklin Yu Aug 24 '18 at 15:36
14

In Ubuntu 18.04, there is no GRUB_HIDDEN_TIMEOUT=0 line in /etc/default/grub - instead there is GRUB_TIMEOUT_STYLE=hidden. According to info -f grub -n 'Simple configuration' :

if this option is unset or set to 'menu', then GRUB will display the menu and then wait for the timeout set by 'GRUB_TIMEOUT' to expire before booting the default entry. Pressing a key interrupts the timeout.

So if you either remove or comment out the line as:

#GRUB_TIMEOUT_STYLE=hidden

then the menu will show by default.

18.04 + Not dual boot, boots in grub 5 seconds:

GRUB_TIMEOUT_STYLE=false

GRUB_TIMEOUT= (no value). Works fine LVM.

8

By default, GRUB will show the menu if there is a second operating system installed. If only Ubuntu is installed, then GRUB will generally load Ubuntu without showing the menu. To reconfigure GRUB to always show a menu:

  1. Edit /etc/default/grub:

    Set GRUB_HIDDEN_TIMEOUT= (no value after the = sign).
    Set GRUB_TIMEOUT=n to show the menu for n seconds.

  2. Run update-grub to regenerate /boot/grub/grub.cfg based on the /etc/default/grub settings.

You can get GRUB to show the menu even if the default GRUB_HIDDEN_TIMEOUT=0 setting is in effect:

  • If your computer uses BIOS for booting, then hold down the Shift key while GRUB is loading to get the boot menu.
  • If your computer uses UEFI for booting, press Esc several times while GRUB is loading to get the boot menu.

Hopefully this clears up confusion as to why Shift works for some users and Esc works for others.

3

I've heard Shift does it. But I've used Space before and it worked.

  • 1
    I've just now tried both Shift and Space, in two situations: In a VM, and "on the metal" ... The "Shift" worked in both situations... The "Space" failed in both situations... – Peter.O Dec 3 '10 at 15:39
  • 4
    If you can't use shift, try escape. Seems to work for me with Ubuntu 12.10. – user530873 Mar 25 '13 at 23:34
  • Ubuntu 15.04. Space key works. Thanks! – DmitryKanunnikoff Oct 8 '15 at 9:11
0

For newer Ubuntu versions there is no GRUB_HIDDEN_TIMEOUT instead there is GRUB_TIMEOUT_STYLE which is set to hidden by default.

Open the file sudo nano /etc/default/grub Change value of GRUB_TIMEOUT_STYLE from hidden to menu and make sure GRUB_TIMEOUT is not set to 0 then run

sudo update-grub

Done!!!

protected by Community Jan 23 '16 at 21:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.