7

I installed some sort of software (I think it had to do with Gnome) that changed the splash image behind the GRUB boot interface from the standard purple background to a somewhat tacky Debian splash image.

Is there any sort of quick set of commands I can enter or file I can delete to change it back to the default background?

8

A quick way to delete the file is --

Opening a terminal by CTRL + ALT + T and execute these command

sudo rm /usr/share/images/desktop-base/desktop-grub.png
sudo update-initramfs -u
sudo update-grub

How that file came

These files are from desktop-base package. That package's function as described in control file is

This package contains various miscellaneous files which are used by Debian Desktop installations. Currently, it provides some Debian-related artwork and themes, .desktop files containing links to Debian related material (suitable for placement on a user's desktop), and other common files between the available desktop environments such as GNOME and KDE.

It includes various wallpapers for both GNOME and EDE, splash screens etc. If you don't want that package, you can remove the package by this command

sudo apt-get purge desktop-base

then executes these commands to restore default grub screen

sudo update-initramfs -u
sudo update-grub

If you want to keep the splash files and want the default grub background

In that case, use the below command to disable checking for grub background file

 sudo chmod -x /etc/grub.d/05_debian_theme

and then execute

sudo update-initramfs -u 
sudo update-grub 
| improve this answer | |
  • It worked, for the most part. It got rid of the Debian wallpaper, although now it has a black background as opposed to the purple one, and after selection the screen stays dark until Ubuntu is finished loading (as opposed to showing the logo and the progress bar). But those are minor, and it is still preferable to that splash image. Is there any way I can manually choose which theme in the /grub.d/ folder to apply? Either way, thanks. – Alex Jul 6 '12 at 15:53
  • @AlexBixel glad that it helps. I have updated the info. you should run sudo update-initramfs -u after removing the file. thanks – Anwar Jul 8 '12 at 8:55
5

A simple way without deleting files or changing file mode bits is:

sudo nano /etc/default/grub

and insert

GRUB_BACKGROUND=""

then run

sudo update-grub
| improve this answer | |
  • 1
    Not sure why this gets downvoted, but it's actually the better answer. – kevin Jan 31 '18 at 7:03
  • Yes, this was exactly the option I was looking for to easily avoid unlocking my encrypted root device. – Johannes Ranke Jan 14 at 17:33
  • Side note for people encrypting /root - it also works to place the background png in /boot/grub, and update-grub. This also avoids having to unlock /root at that stage. – Johannes Ranke Jan 14 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.