When I tried to install Ubuntu from the live CD start menu, the screen became black with just a blinking cursor. I rebooted the PC and I chose the option acpi=off. Then the installer started and Ubuntu installed whitout problems.

But when I reboot the PC now after the installation was complete the screen goes black again. I am new in the use of Ubuntu.

up vote 31 down vote accepted

Please add acpi=off to the kernel command line -- it's just slightly different than doing it with the LiveCD:

  1. Press the Shift when booting up, to get the Grub menu. Use the arrow keys to navigate/highlight the entry you want (usually the first one).

    enter image description here

  2. Press e to edit that entry, which will show you the details:

    enter image description here

  3. Find the linux entry as shown above, use the arrow keys to get to it, and then press the End key to get to that line's end (which may be on the next line!). Enter acpi=off as shown, and press Ctrl+X to boot.

  4. You can make this workaround permanent by:

    • sudo nano /etc/default/grub
    • Change line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"
    • Ctrl-X, press Y and then Enter to save and exit.
    • sudo update-grub
    • Reboot and you should no longer have the black screen problem.

See also:

Use Boot-Repair's Advanced options to add acpi=off (or any other kernel option) to your GRUB in 1 click. It will also provide a BootInfo summary if you need more help.

enter image description here

See also: https://help.ubuntu.com/community/BootOptions#Changing_boot_options_Permanently_for_an_Existing_Installation

  • after disabling acpi, wifi and ethernet are not working and interfaces are not listing at all. I am using MSI GE62 with Ubuntu 15.04. – Chandana Apr 9 '16 at 5:01

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.