9

While typing normal keys I have to press fn (function key) as it seems that the function key is pressed all the time.

What do I have to do to turn the function key off and it trigger it only when I press on it.

  • 2
    It sounds like the key is stuck. Try carefully removing the key, and clean it, and underneath it. – Mitch Jul 5 '12 at 7:47
12

Finally I got the solution, after doing some random key pressing!

Infact there was key numLk, so i again press Fn+numLk and my keys started working properly.

  • I had the same issue... weird though that it gets "pressed" automatically at reboot.. – lucacerone Nov 3 '13 at 12:09
  • I had this issue after using a USB keyboard for a while and using NumLock on it. Maybe Ubuntu should automatically switch between On and Off when changing keyboards. – Pablo Sep 11 '16 at 22:26
  • Same here. had to click Fn+Esc (where the "lock" symbol appears), Latitude E7470 – Bruno Bossola Nov 17 '16 at 13:22
7

Try to press ESC(FnLk)+Fn. This help for my Ubuntu 14.04 LTS + Lenovo Thinkpad E540.

  • What is FnLk .? – Tim Aug 20 '14 at 13:14
  • @Tim FnLk is Function Lock. This really does apply to some laptop keyboards. – Eliah Kagan Aug 20 '14 at 14:54
1

There might be a setting in your BIOS for this. I know that some laptops use the F1-F12 keys for special functions and require the function key to be pressed for normal key use. Try running your BIOS setup while booting and look for an option you can change.

  • Okay I will look into it! – Vivek Kumar Jul 5 '12 at 15:59
  • I have checked into the BIOS for keyboard/function key setting, But I didn't get any. Moreover I found while entering the password at startup. Normal keys are working, But after logged into, pressing the same key result as if that key is pressed with function key. Is there some way I can fix it? – Vivek Kumar Jul 6 '12 at 6:18
  • Any help please?? – Vivek Kumar Jul 8 '12 at 14:19
1

Lately I've been having the same problem across Ubuntu 10.04 (LinuxCNC edition), 11.04, and the late stable 12.04. I have an Acer Aspire 4535. The combo Fn + numLk doesn't work and my BIOS doesn't have any key customization, and then I've found the error message about Compiz in Ubuntu 12.04 and tried reinstall it with the following command:

sudo apt-get install compizconfig-settings-manager

And now the Fn key is back under control. I almost thought this was a hardware problem. I'm a newbie using Ubuntu so i don't know what actually happened to Compiz, it just works now.

protected by Braiam Aug 31 '15 at 19:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.