9

This question already has an answer here:

Tried to boot Ubuntu, but this shows up instead:

grub rescue>

marked as duplicate by Eric Carvalho, Zanna, user68186, Pabi, ravery Jan 16 '18 at 3:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • did you installed Ubuntu correctly? Have you ever booted your system after installation – Anwar Jul 5 '12 at 6:59
  • Please indicate your BootInfo URL to provide more information about your system. – LovinBuntu Jul 5 '12 at 21:33
31
+50

If you were able to boot Ubuntu in the past, but not now, follow these steps to solve the problem.

  • First type ls command and Press Enter to see all the available partitions. The entries will be shown as (hd0,msdos1) (hd0,msdos2) (hd0,msdos5) etc.

  • Then type ls (hd0,msdos1)/ to see the content of the drive. if you see entries like vmliuz or initrd, it is your Linux partition. If you fail with (hd0,msdos1), try with (hd0,msdos2) and so on, until you recognize your Ubuntu partition.

  • When you correctly identify your Ubuntu partition, type root=(hdX,msdosX) , replace the X with correct identified number. For example, if you see vmlinuz and initrd entries by entering ls (hd0,msdos5), the command will be root=(hd0,msdos5).

  • then type configfile /boot/grub/grub.cfg and type Enter. This will bring you Previous Ubuntu grub menu.

  • Then choose the entry to boot Ubuntu.

  • After you booted up, Open a terminal and type sudo update-grub and press Enter. This will update the grub menu and prevent future problems.

In the case that you are not able to boot to Ubuntu after installation, re-installing Ubuntu is the best option. You can check this question:

  • 2
    No, I have never been able to boot. And this did not help. I've been having so many problems with Ubuntu... – KalebNoobMaster Jul 5 '12 at 12:22
  • 2
    Didn't work for me. After entering "configfile ..." it went back to the grub prompt, not the menu. – Vituel May 7 '15 at 11:54
  • You can try insmod normal. See if work, since this answer is for Grub-Legacy – Anwar May 8 '15 at 15:31
  • You are my hero – Primusa Mar 15 at 0:08
-1

Disconnecting my Windows 7 drive fixed this.

  • 2
    I doubt that is applicable, desirable, or even possible in most circumstances. – David Foerster May 12 '16 at 21:57
  • I tried the top answer, but did not see any files on the ubuntu drive. Also, it may be preferable to not change anything in the boot config if you can avoid it. – crizCraig May 13 '16 at 20:54
  • @DavidFoerster it is, if USB drive shows as hd0, then Ubuntu will not boot. – Mark Yisri Nov 13 '16 at 19:24
  • @MarkYisri: If you're still not using UUIDs or labels to set root in Grub (which is the default behaviour in Ubuntu since at least a few years), you're doing it wrong. – David Foerster Nov 13 '16 at 19:49
-1

If you still haven't got it to work, I would recommend (and this is the absolute LAST option) a full Ubuntu reinstall. If you have a flash drive with at least 3 Gigabytes of storage space, and you have the time and means to do so, reinstall Ubuntu using the following method:

Using your Windows drive, download Rufus from here.

Download your desired Ubuntu .iso file from here.

After the .iso file is downloaded, open Rufus and plug in your USB drive. Go to Create a bootable disk using and select ISO Image. Find and select the desired .iso image and click Start. The rest is as simple as waiting for it to install and booting from the drive.

  • 3
    what does this add to the other answer? – Mark Yisri Nov 13 '16 at 19:24
  • If it's not fixed, it provides a last resort. – Krieger Nov 18 '16 at 3:05
  • 2
    the other answer talks about reinstall too – Mark Yisri Nov 18 '16 at 13:25
-2

I know this will sound irrelevant but after several restart attempts and before reading any posts, i decided to go to the bios in the scope of trying a restore defaults and / or change booting sequences. The problem was solved just by pressing F2 several times, including at the very moment Grub was supposed to start. I restarted a few times since then without any issues. My config is a dual booting with Ubuntu 12.04 & Windows 7

Hope it works for someone else

-2

For newer versions of ubuntu (16.04 ), this happens because ubuntu is trying to load in UEFI mode. But the usual install is Legacy mode, so go to BIOS->Boot Option->Select your Hard Disk and not UEFI Hard Disk.

-3

When this happened to me it was because I swaped out a drive that I made a line in fstab for it. Swaped the drive in and resolver the problem. Then added error=continue

  • the kernel won't even boot, how will this help the OP? – Mark Yisri Nov 13 '16 at 19:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.