I have Adobe CS5 installed and running on the Windows 7 side of my machine. Since I'd hate to boot up into Windows just to use Photoshop, I'm trying to get it in Ubuntu 12.04.

Tutorials I found suggested that the easiest way to have it in Ubuntu was to install Wine, and copy my Windows installation over.

Here are the exact steps I've done up to this point.

From Windows, exported the registry key for HKEY_LOCAL_MACHINE >> SOFTWARE >> Adobe to the desktop.

Changed to Ubuntu, downloaded Wine from Software Center

$ sudo apt-get install wine ttf-mscorefonts-installer
$ winecfg
$ wget http://www.kegel.com/wine/winetricks
$ sh winetricks msxml6 gdiplus gecko vcrun2005sp1 vcrun2008 msxml3 atmlib

Moved registry export to home folder.

"Program Files (x86)\Adobe" to "~/.wine/drive_c/Program Files (x86)/Adobe"

"Program Files (x86)\Common Files\Adobe" to "~/.wine/drive_c/Program Files (x86)/Common Files/Adobe"

"Documents and Settings\Don\Application Data\Adobe" to "~/.wine/drive_c/users/don/Application Data/Adobe"

"Windows\System32\odbcint.dll" to "~/.wine/drive_c/windows/system32/odbcint.dll" ,and lastly

"Windows\System32\odbc32.dll" to "~/.wine/drive_c/windows/system32/odbc32.dll".

From Terminal, $ wine regedit adobe.reg.

Right clicked on Photoshop.exe and selected "Open with Wine".

Got the message "Wine Program Crash, Internal errors - invalid parameters received."

So to restate my question, How can I get Photoshop running in Ubuntu 12.04? I'm not sold on doing it in this specific way, I just want to use Photoshop without having to reboot. What's the best way to make this happen?

Edit: I do not have the installation CD, no.

  • 1
    Do you not have the installation cd? Jul 5, 2012 at 1:15

2 Answers 2


You can install Adobe Photoshop CS4 in Ubuntu. For that you have to install PlayonLinux. Please follow this procedure to install it in your ubuntu.


Ubuntu Software Center > Edit > Preference

Then select "Other Software" tab. Click on add and copy/paste

deb http://deb.playonlinux.com/ precise main

Click add source and close it.

Then open a terminal. Type

sudo apt-get update

sudo apt-get install playonlinux

After finishing installation run PlayOnLinux from Game or search it in dash.

Run the program. 1st time it will install some windows base font. Follow the instruction. It may take a while. After finishing click on Install a program.

A window will appear with list of software. From left click Graphics and then select Adobe Photoshop CS4 and then click Install button to install it. After installing you can find it in graphics menu. Hope it would help.

  • Did you try it? Please let me know if you tried...
    – Kaktarua
    Jul 13, 2012 at 9:53
  • I tried this many different ways. Unfortunately, I still encountered the same error every time.
    – user70540
    Jul 14, 2012 at 22:39
  • It works for me. By the way try again by removing and installing wine & winetricks
    – Kaktarua
    Jul 14, 2012 at 22:41
  • I got it working, although with a different method. Thanks for trying to help.
    – user70540
    Jul 14, 2012 at 22:44
  • As I understand it, one way or another the bounty is lost from my perspective, so I'm going to give it to you for giving me a good, detailed answer. Thanks again for your help.
    – user70540
    Jul 14, 2012 at 23:31

I've finally managed to do this.

I cleared my Ubuntu partition of all Photoshop,wine,winetricks, and PlayOnLinux files (not that I think that was essential to the process), reinstalled wine and winetricks and followed the tutorial listed here:


Then I put a script on the desktop to launch it.

There is still a slight problem: When it runs, a message pops up notifying me of a problem using the C runtime library. The only problem this seems to cause is the message box (which I can just leave until I'm finished), and that all the file menu names are prepended with an ampersand(&). This is a purely aesthetic problem, and there's no problem with functionality as far as I have noticed.

EDIT: The problem with the C runtime library was caused by plugins. Went to the plugin menu, disabled everything, restarted the program, and the error was nowhere to be found.

Still have the ampersands though.

You must log in to answer this question.