2

I just installed Ubuntu 12.04 along with Windows 7 on the same laptop - Dell Vostro 3560. Now, on Windows 7 I can access to different wi-fi networks. However, when I am logging onto the Ubuntu section (after re-starting my laptop) - an error message appears:

Disconnected - you are now offline

When I take a look at my network menu (in the upper bar on the screen), I see that no network is found (and I have a few of them in the area. ).

I tried to look around but really could not find a concrete practical solution to this specific problem, would appreciate any solution from anyone out there that had this problem and solved it.

developer@ubuntu:~$ sudo lspci -nn 
00:00.0 Host bridge [0600]: Intel Corporation Ivy Bridge DRAM Controller [8086:0154] (rev 09)
00:01.0 PCI bridge [0604]: Intel Corporation Ivy Bridge PCI Express Root Port [8086:0151] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation Ivy Bridge Graphics Controller [8086:0166] (rev 09)
00:14.0 USB controller [0c03]: Intel Corporation Panther Point USB xHCI Host Controller [8086:1e31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation Panther Point MEI Controller #1 [8086:1e3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation Panther Point USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation Panther Point High Definition Audio Controller [8086:1e20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation Panther Point PCI Express Root Port 1 [8086:1e10] (rev c4)
00:1c.1 PCI bridge [0604]: Intel Corporation Panther Point PCI Express Root Port 2 [8086:1e12] (rev c4)
00:1c.2 PCI bridge [0604]: Intel Corporation Panther Point PCI Express Root Port 3 [8086:1e14] (rev c4)
00:1d.0 USB controller [0c03]: Intel Corporation Panther Point USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation Panther Point LPC Controller [8086:1e57] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] [8086:1e03] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation Panther Point SMBus Controller [8086:1e22] (rev 04)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Thames XT/GL [Radeon HD 7600M Series] [1002:6840]
07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 07)
08:00.0 Network controller [0280]: Broadcom Corporation Device [14e4:4365] (rev 01)
  • web-e's suggestion of searching for additional drivers didn't show anything

@WEB-E , you suggested that i do the following:
1.check for additional drivers - did not show any relevant result
2. run the lspci -vvv command in the terminal. the relevant result (communication - ethernet, etc.:

07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 07)
    Subsystem: Dell Device 056e
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 43
    Region 0: I/O ports at 3000 [size=256]
    Region 2: Memory at c3404000 (64-bit, prefetchable) [size=4K]
    Region 4: Memory at c3400000 (64-bit, prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: r8169
    Kernel modules: r8169

08:00.0 Network controller: Broadcom Corporation Device 4365 (rev 01)
    Subsystem: Dell Device 0016
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 11
    Region 0: Memory at c3500000 (64-bit, non-prefetchable) [size=32K]
    Capabilities: <access denied>

Thank you WEB-E for still commentating, i'll appreciate you further response :-)

0

I could not get the exact hardware details of that model from the internet. However you should check for additional drivers to get proprietary driver. Please follow the steps,

  • Connect to internet by some other method.

  • Press Alt + F2 , type gksu jockey-gtk

  • Press Enter

This will search for additional drivers required to install. Install the wi-fi driver if you see it on list.

If the above steps doesn't work. Open a terminal by pressing Alt+ Ctrl + T , run the command lspci -vvv and post the result.

You can edit your question to post that result.

| improve this answer | |
0

Maybe wifi driver problem.

Try like this

First we have to remove the bcmwl kernel source: sudo apt-get remove bcmwl-kernel-source

Then again install : sudo apt-get install bcmwl-kernel-source

| improve this answer | |
0

Try this. See if this helps. Just a suggestion.

Open the terminal window. Type the following:

sudo ubuntu-drivers

autoinstall

sudo reboot

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.